UnrealIRCd Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0003013unrealdocumentationpublic2006-08-01 20:412012-10-17 18:06
ReporterMuisje 
Assigned ToStealth 
PrioritynormalSeverityminorReproducibilityN/A
StatusfeedbackResolutionopen 
PlatformanyOSanyOS Versionany
Product Version3.2.5 
Target VersionFixed in Version 
Summary0003013: Update for help.conf & technical document
DescriptionI have noticed people thinking that svs commands are there to haven, however you can tell them it's bad for a million times and they will still ask how to use them. There for i think it's best that from the default help configuration file has an index change. With the idea to have the line " /HELPOP SVSCMDS - Commands sent via U:Lined Server (Services)" removed from the index.
This way the help will still be there, but just not advertised for newcomers to play with them.

Also i read the serverprotocol file (Wich is under technical dir) which has an error in it. (You can read it's part in the additional information.) There it states in the Syntax line : should be used before providing protocol options, however this is wrong. Sending it with : will cause the server to ignore them. So since you need to leave it out, i think it's best to just remove the : out of the documentation.
Additional Information2.2 PROTOCTL - Server Protocol Negotiation
Syntax: PROTOCTL :protocol options

The PROTOCTL command sets several protocol options. The tokens supported are listed below.
TagsNo tags attached.
3rd party modules
Attached Files

- Relationships

-  Notes
(0012151)
Muisje (reporter)
2006-08-04 21:02

Also the NICK introducing part is incorrect (Source.server isn't sent.)
(0012702)
aquanight (reporter)
2006-11-22 15:44

NICK and TOPIC fixed in devel branch CVS .2301.

Leaving open for SVSCMDs helpop stuff... Really now that these are mostly documented in serverprotocol, is it even necessary to keep any of them?
(0015227)
Stealth (administrator)
2008-03-16 16:49

3.3 - Removed SVS commands from help.conf and put them in help.svscmds.conf
(0016720)
syzop (administrator)
2011-07-19 18:11

Reconsider this.
Our options:
1) Move it to a different file, like in the way this bug was resolved.
2) Remove it, because it belongs in serverprotocol.html and not in help.conf
(0017085)
syzop (administrator)
2012-08-17 13:48

I'd like to go with option 2. For two reaons: First, I don't see why server (services) related documentation should be in HELPOP. Second, whenever you duplicate stuff (have it at multiple places) almost always one gets out of synched or has information the other source hasn't, which is bad since if someone finds documentation at place X, he isn't going to look any further.

Any objections?

If not, feel free to make a patch for help.conf. It's not really on my TODO list, has no priority, TBH.
(0017091)
Muisje (reporter)
2012-08-17 22:31

I hardly forgotten i ever posted this... :)

Good to see that after 6 years there is finally attention payed.

Don't like to bitch and it's not really high to any priority but 6 years... well i hope that this is the only case otherwise the support really is bad.

Decide what you want, maybe in another 6 years it will be done by someone.
(0017092)
warg (reporter)
2012-08-18 02:01

Muisje, there has been more important things to work on in the last 6 years with only a few devs at any given time. If you had submitted a patch to correct the problem, it probably would have been done 6 years ago.

Thanks for your report.
(0017185)
syzop (administrator)
2012-10-17 18:06
edited on: 2012-10-17 18:06

<Stealth> Syzop, can you slip in 0003013?
<Stealth> I like Option 2, just remove the SVS commands from help.conf

I don't want to bother our translators with major changes for 3.2.10 anymore, sorry.

If you, or anyone else, creates a patch which:
1) Removes all SVSCMDS from help.conf
2) Add any non-existing services commands to doc/technical/serverprotocol.html
This way, no information will be 'lost'. serverprotocol.html already contains a lot of services commands, so I think only a few commands would need to be added.

If such a patch is made, then I'll put it in after 3.2.10 release.

Also - just a generic comment - if anyone feels like serverprotocol.html would be helped by other improvements/modifications/.. then be my guest :).


- Issue History
Date Modified Username Field Change
2006-08-01 20:41 Muisje New Issue
2006-08-04 21:02 Muisje Note Added: 0012151
2006-11-22 15:35 aquanight Status new => assigned
2006-11-22 15:35 aquanight Assigned To => aquanight
2006-11-22 15:44 aquanight Note Added: 0012702
2008-03-16 16:46 Stealth Assigned To aquanight => Stealth
2008-03-16 16:49 Stealth QA => Not touched yet by developer
2008-03-16 16:49 Stealth U4: Need for upstream patch => No need for upstream InspIRCd patch
2008-03-16 16:49 Stealth Status assigned => resolved
2008-03-16 16:49 Stealth Fixed in Version => 3.3-alpha0
2008-03-16 16:49 Stealth Resolution open => fixed
2008-03-16 16:49 Stealth Note Added: 0015227
2008-03-16 16:50 Stealth Relationship added child of 0003049
2011-07-19 18:11 syzop Note Added: 0016720
2011-07-19 18:11 syzop Status resolved => feedback
2011-07-19 18:11 syzop Resolution fixed => open
2011-07-19 18:11 syzop Fixed in Version 3.3-alpha0 =>
2012-08-17 13:48 syzop Note Added: 0017085
2012-08-17 22:31 Muisje Note Added: 0017091
2012-08-18 02:01 warg Note Added: 0017092
2012-10-17 18:06 syzop Note Added: 0017185
2012-10-17 18:06 syzop Note Edited: 0017185 View Revisions


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker