View Issue Details

IDProjectCategoryView StatusLast Update
0005165unrealircdpublic2018-12-08 13:09
ReporterSt3Nl3yAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.18 
Target VersionFixed in Version4.2.1 
Summary0005165: Changing nick to a banned nick
DescriptionIt is possible to change nick while nick!*@* is banned on the channel.
Changing back while on banned nick is not possible.
Steps To Reproduce[03-12-2018][16:20:46] * Stanley sets mode: +b test!*@*
[03-12-2018][16:21:21] * |join| Stenly (hfpejgcsot@Stanley.loves.Claudje.4.Ever) joinde #eindbazen - laatst gezien 1d 3h 19m 7s ago (4 gebruikers)
[03-12-2018][16:21:34] Stenly heeft zijn/haar naam veranderd in test
Additional Information[03-12-2018][16:20:46] * Stanley sets mode: +b test!*@*
[03-12-2018][16:21:21] * |join| Stenly joinde #eindbazen - laatst gezien 1d 3h 19m 7s ago (4 gebruikers)
[03-12-2018][16:21:26] * |channel| retrieving #eindbazen modes...
[03-12-2018][16:21:34] Stenly heeft zijn/haar naam veranderd in test
 
#test nick#
[16:21:34] Stenly heeft zijn/haar nickname veranderd in test.
#changing back because banned nick
[16:21:41] Cannot change nickname while banned on channel "#eindbazen"
TagsNo tags attached.
3rd party modules

Activities

St3Nl3y

2018-12-03 16:37

reporter   ~0020386

Typing while banned on regular mode not possible, on voice mode it is:
[16:35:00] <test> burp
[16:35:00] You are banned (#eindbazen)
[16:36:25] Stanley zet modus +v test
[16:36:33] <test> burp

The_Myth

2018-12-05 05:59

reporter   ~0020389

I can confirm the issue even with set::check-target-nick-bans explicitly set to yes.
According to the wiki:
/*
* set::check-target-nick-bans
*
* Syntax: set::check-target-nick-bans <yes|no>
*
* Whenever the user changes his/her nick, check if the NEW nick would be banned. If so, do not allow the nickchange. Default is yes.
*/

By my understanding we shouldn't be able to change to the banned mask.

Cheers

syzop

2018-12-08 13:09

administrator   ~0020391

Fixed, thanks for the report!

https://github.com/unrealircd/unrealircd/commit/84686f02bb9dce5dfa56d653f6cf2280ad0e4ac0

commit 84686f02bb9dce5dfa56d653f6cf2280ad0e4ac0
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sat Dec 8 13:01:27 2018 +0100

    Fix checking for target nick bans (cannot change to a nick that is banned).
    This was and still is the default, set::check-target-nick-bans 'yes', however
    the feature was broken since UnrealIRCd 4.0.0 (-betaX) by commit
    709c7e890ea99e3a8cdca71a5df1831be7bb3f80. Reported by PeGaSuS and St3Nl3y.

Issue History

Date Modified Username Field Change
2018-12-03 16:31 St3Nl3y New Issue
2018-12-03 16:37 St3Nl3y Note Added: 0020386
2018-12-05 05:59 The_Myth Note Added: 0020389
2018-12-08 13:09 syzop Assigned To => syzop
2018-12-08 13:09 syzop Status new => resolved
2018-12-08 13:09 syzop Resolution open => fixed
2018-12-08 13:09 syzop Fixed in Version => 4.2.1
2018-12-08 13:09 syzop Note Added: 0020391