View Issue Details

IDProjectCategoryView StatusLast Update
0005209unrealircdpublic2019-04-22 20:59
ReporterrazingedenAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version18.06
Product Version4.2.1 
Target VersionFixed in Version 
Summary0005209: With privdeaf module loaded and +D mode mode on connect enforced (locked), a uline service cannot set user -D
DescriptionWith privdeaf module loaded and +D mode mode on connect enforced (locked), a uline service cannot set user -D
Steps To Reproduceset modes-on-connect +DR
set restrict-usermodes DR
loadmodule “usermodes/privdeaf.so”

with a UMODE2 command such as anope 2.0.6 you can /os mode user (plus or minus any mode except -D)

Should I not be able to forcibly change a user mode at my discretion?

I initially thought this was because I restricted user mode D

However on subsequent testing I restricted user mode R , and that one I can set and unset as a service with a UMODE2 protocol command
 
TagsNo tags attached.
3rd party modulesprivdeaf.so

Activities

razingeden

2019-02-18 09:28

reporter   ~0020490

I installed 4.2.2-rc2
This time I did not restrict the user mode to D
Or lock to user mode D (in ircd config)

I remained unable to put another user in +D
Or take them out of +D.

Repeated the test and could +R and -R the same user.

The Target user is not an /oper

Initially this fooled me because I assumed I couldn’t do that to an /oper

Turns out I can’t do it to anyone !

razingeden

2019-02-18 09:52

reporter   ~0020491

Disregard I figured out how to support it in anope itself. Not an unreal ircd bug

Issue History

Date Modified Username Field Change
2019-02-18 09:12 razingeden New Issue
2019-02-18 09:28 razingeden Note Added: 0020490
2019-02-18 09:52 razingeden Note Added: 0020491
2019-04-22 20:59 syzop Assigned To => syzop
2019-04-22 20:59 syzop Status new => closed
2019-04-22 20:59 syzop Resolution open => no change required