View Issue Details

IDProjectCategoryView StatusLast Update
0005310unrealinstallingpublic2019-11-17 15:47
ReportersyzopAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.2.3 
Target VersionFixed in Version5.0.0-rc2 
Summary0005310: FreeBSD: require gmake
DescriptionOn FreeBSD we should output an error during ./configure if gmake is not installed, since without gmake compilation will fail.

See: https://forums.unrealircd.org/viewtopic.php?f=45&p=39153
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-05-30 17:36

administrator   ~0020714

(I was able to reproduce the issue)

syzop

2019-11-17 15:47

administrator   ~0021073

Last edited: 2019-11-17 15:47

View 2 revisions

yang reported the same issue on NetBSD.

I've updated configure so it now prints (without gmake) the following, very early in the configure process:
configure: error: It seems your system does not have gmake installed. Please install gmake.

commit 74bbc92cf0cb65fb70f8e1a15458c550518d21a9 (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sun Nov 17 15:46:45 2019 +0100

    Make configure exit when no GNU Make is present (eg no 'gmake' on *BSD).
    https://bugs.unrealircd.org/view.php?id=5310

Issue History

Date Modified Username Field Change
2019-05-30 17:36 syzop New Issue
2019-05-30 17:36 syzop Status new => confirmed
2019-05-30 17:36 syzop Note Added: 0020714
2019-11-17 15:47 syzop Assigned To => syzop
2019-11-17 15:47 syzop Status confirmed => resolved
2019-11-17 15:47 syzop Resolution open => fixed
2019-11-17 15:47 syzop Fixed in Version => 5.0.0-rc2
2019-11-17 15:47 syzop Note Added: 0021073
2019-11-17 15:47 syzop Note Edited: 0021073 View Revisions