View Issue Details

IDProjectCategoryView StatusLast Update
0001763unrealircdpublic2007-04-27 05:45
ReporterExcelsior Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwont fix 
Product Version3.2 
Summary0001763: OperOverride notices are given when person being kicked is +oh and oper is +oh.
Description
[19:48:52] -m00.on.ca.zirc.org- *** OperOverride -- Excelsior (Excelsior@12-214-207-88.client.mchsi.com) KICK #octeams Cluster (Cluster)

I am +oh, as well as Cluster is +oh, I Am an oper, I kicked him. The IRCd is seeing +h and is thinking since we're both +h and I kicked him, I must be overriding. It was reproduced successfully time and time again in other channels.
Steps To ReproduceSet Person A and person B +oh.
Have person A kick person B (person A being opered up)
Recieve override notice, although there was no override.
TagsNo tags attached.
3rd party modules

Activities

aquanight

2004-04-27 09:36

reporter   ~0005932

Get rid of the +h. If you have +o you don't need +h because all the permissions of +h are included in +o. Do that, then you should be able to /kick w/o the override message.

Though, it's true that the IRCd should not trigger an override in this situation because you have the permissions from +o.

There are, of course, other things that may have caused the override to trigger: channelmode +Q and usermode +q in particular. You did check these before posting, right? Normally, when the channel is +Q only users with umode +S (as well as U:Lined servers) can /kick people, and people with umode +q can only be kicked by +S users (and U:Lined servers).

Excelsior

2004-04-27 17:17

reporter   ~0005934

" Get rid of the +h. If you have +o you don't need +h because all the permissions of +h are included in +o. Do that, then you should be able to /kick w/o the override message.

Though, it's true that the IRCd should not trigger an override in this situation because you have the permissions from +o.

There are, of course, other things that may have caused the override to trigger: channelmode +Q and usermode +q in particular. You did check these before posting, right? Normally, when the channel is +Q only users with umode +S (as well as U:Lined servers) can /kick people, and people with umode +q can only be kicked by +S users (and U:Lined servers)."

Yes I know all permissions are allowed with +o that come with +h. I did check if there were any channel modes that would be causing the override, and I tried in an empty channel, and it still did it. Just a minor thing the IRCd shouldn't trigger an override for, since it seemed to cause a bit of alarm needlesly. :P

-Excelsior

w00t

2004-04-29 19:45

reporter   ~0005957

Hm... Yes, why indeed is it triggering overrides... Looks like a block of code is in the wrong place.

stskeeps

2007-04-27 05:45

reporter   ~0013838

Please re-submit for 3.3 or 3.2.6/7 instead if this issue still exists.

Issue History

Date Modified Username Field Change
2004-04-26 21:28 Excelsior New Issue
2004-04-27 09:36 aquanight Note Added: 0005932
2004-04-27 17:17 Excelsior Note Added: 0005934
2004-04-29 19:45 w00t Note Added: 0005957
2007-04-27 05:45 stskeeps Status new => closed
2007-04-27 05:45 stskeeps Note Added: 0013838
2007-04-27 05:45 stskeeps Resolution open => wont fix