View Issue Details

IDProjectCategoryView StatusLast Update
0001542unrealinstallingpublic2004-03-05 17:48
Reportersyzop Assigned Tocodemastr 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platformia32OSLinux / Mandrake 
Product Version3.2-RC1 
Summary0001542: configure/c++ compiler
DescriptionSomeone mailed me with a compile problem a few hours ago, as you can see (in "additional information") it doesn't find a C++ compiler but still continues a bit...
So the 2 things are: 1. Shouldn't it stop/abort directly after that (like it's even trying to compile TRE..), 2. why is it checking for C++ in the first place.. is it required (like for TRE)?
I told him just to install a C++ compiler (g++), but perhaps we could ""fix"" this... it's however a minor thingy of course :).
Additional Informationchecking whether we are using the GNU C++ compiler... no
checking whether g++ accepts -g... no
checking dependency style of g++... none
checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
compiling TRE regex library
gmake: *** No targets specified and no makefile found. Stop.
installing TRE regex library
gmake: *** No rule to make target `install'. Stop.
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/modules/Makefile
config.status: creating unreal
config.status: creating ircdcron/ircdchk
config.status: creating include/setup.h
config.status: include/setup.h is unchanged
SSL certificate already existing, no need to regenerate
Building src
make[1]: Entering directory `/home/alpha/Unreal3.2/src'
gcc -I../include -I/home/alpha/Unreal3.2/extras/regexp/include -pipe -g -O2 -funsigned-char -I/usr/local/ssl/include -I/usr/local/include -DZIP_LINKS -export-dynamic -L/usr/local/ssl/lib -L/usr/local/lib -c auth.c
In file included from auth.c:21:
../include/struct.h:65:23: tre/regex.h: No such file or directory
In file included from auth.c:21:
../include/struct.h:748: error: syntax error before "regex_t"
../include/struct.h:748: warning: no semicolon at end of struct or union
In file included from auth.c:21:
../include/struct.h:1130: error: syntax error before "regex_t"
../include/struct.h:1130: warning: no semicolon at end of struct or union
../include/struct.h:1206: error: syntax error before "regex_t"
../include/struct.h:1206: warning: no semicolon at end of struct or union
make[1]: *** [auth.o] Error 1
make[1]: Leaving directory `/home/alpha/Unreal3.2/src'
make: *** [build] Error 2
TagsNo tags attached.
3rd party modules

Activities

2004-02-14 18:41

 

configandmakelog.txt (9,208 bytes)

syzop

2004-02-14 21:10

administrator   ~0005002

Added a FAQ entry on it: http://www.vulnscan.org/UnrealIrcd/faq/#62

codemastr

2004-02-15 01:41

reporter   ~0005003

I've done a little research. The code that checks for the C++ stuff, as well as the Fortran garbage is within the AC_PROG_LIBTOOL macro. This macro is used in order to add libtool support.

codemastr

2004-02-15 01:52

reporter   ~0005004

There seems to be an AC_LIBTOOL_TAGS that can disable that stuff, not sure how to use though.

codemastr

2004-02-15 21:43

reporter   ~0005014

Well here's the problem, libtool has no documentation! First off, AC_LIBTOOL_TAGS doesn't seem to be mentioned anywhere on the libtool website. Then --with-tags (which seems to do the same thing?) is also not documented anywhere. Maybe you know someone who knows a bit about libtool?

syzop

2004-02-15 21:53

administrator   ~0005015

googled a bit and found:
http://www.mail-archive.com/libtool@gnu.org/msg04628.html
http://linuxfromscratch.org/pipermail/alfs-log/2003-December/000785.html
http://cvs.sourceforge.net/viewcvs.py/dhcp-agent/dhcp-agent/configure.ac?rev=1.20
however, I've no idea if it's helpful since I don't understand a thing of it :p.

syzop

2004-02-15 21:55

administrator   ~0005016

Last edited: 2004-02-15 21:58

or is it, because it's 1.6* specific (??), not really a solution? :|

Or can we write a macro ourself.. or however it works. <-- *edit* uh, nevermind.. bad idea.. lol ;p */edit*

edited on: 2004-02-15 21:58

codemastr

2004-02-15 21:56

reporter   ~0005017

Yeah I've seen that as well, I don't get it either.

syzop

2004-02-15 22:02

administrator   ~0005018

Just found some stuff... seems that option is only in the CVS version (of which the download link doesn't work but cvs itself does:):
export CVS_RSH=ssh
cvs -z3 -d :ext:anoncvs@savannah.gnu.org:/cvsroot/libtool co libtool

vulnscan:/tmp/x/libtool# grep AC_LIBTOOL_TAGS . -r
./ChangeLog.2003: * NEWS: Mention AC_LIBTOOL_TAGS.
./ChangeLog.2003: the tags we need using AC_LIBTOOL_TAGS, reducing the size of the
./ChangeLog.2003: * m4/libtool.m4 (AC_LIBTOOL_TAGS, AC_ENABLE_SHARED,
./ChangeLog.2003: AC_LIBTOOL_TAGS, _LT_AC_TAG_CHECK, _LT_AC_TAG_CONFIG,
./ChangeLog.2003: Makes it work again if AC_LIBTOOL_TAGS is specified in configure.ac.
./ChangeLog.2003: * doc/libtool.texi (AC_LIBTOOL_TAGS): Incorporate documentation
./ChangeLog.2003: for AC_LIBTOOL_TAGS macro to specifify libtool tags. The now
./ChangeLog.2003: with a new AC_LIBTOOL_TAGS([tag1 tag2 ...]) macro. Deprecate
./NEWS:* New AC_LIBTOOL_TAGS macro to limit configure checks to only the listed tags.
./doc/libtool.texi:@defmac AC_LIBTOOL_TAGS ([tag1 tag2 ...])
./m4/libtool.m4:# AC_LIBTOOL_TAGS
./m4/libtool.m4:AC_DEFUN([AC_LIBTOOL_TAGS],
./m4/libtool.m4:]) # AC_LIBTOOL_TAGS
./m4/libtool.m4:[AC_PROVIDE_IFELSE([AC_LIBTOOL_TAGS], [], [
./m4/libtool.m4: AC_LIBTOOL_TAGS([CXX F77 GCJ RC])])dnl
./tests/cdemo/configure.ac:AC_LIBTOOL_TAGS([])
./tests/demo/configure.ac:AC_LIBTOOL_TAGS([])
./tests/depdemo/configure.ac:AC_LIBTOOL_TAGS([])
./tests/f77demo/configure.ac:AC_LIBTOOL_TAGS([F77])
./tests/mdemo/configure.ac:AC_LIBTOOL_TAGS([])
./tests/mdemo2/configure.ac:AC_LIBTOOL_TAGS([])
./tests/pdemo/configure.ac:AC_LIBTOOL_TAGS([])
./tests/tagdemo/configure.ac:AC_LIBTOOL_TAGS([CXX])

I guess NEWS, libtool.texi and the tests should help you further :p.

codemastr

2004-02-15 22:12

reporter   ~0005019

I sent the TRE author an email, hopefully he can fix it (and soon). If not I'll try and play around, but I don't know much about automake/libtool.

syzop

2004-02-15 22:59

administrator   ~0005021

ok :).

codemastr

2004-03-05 17:48

reporter   ~0005307

Fixed in .2160

Issue History

Date Modified Username Field Change
2004-02-14 18:20 syzop New Issue
2004-02-14 18:21 syzop Category documentation => installing
2004-02-14 18:41 syzop File Added: configandmakelog.txt
2004-02-14 21:10 syzop Note Added: 0005002
2004-02-15 01:41 codemastr Note Added: 0005003
2004-02-15 01:52 codemastr Note Added: 0005004
2004-02-15 21:43 codemastr Note Added: 0005014
2004-02-15 21:53 syzop Note Added: 0005015
2004-02-15 21:55 syzop Note Added: 0005016
2004-02-15 21:56 codemastr Note Added: 0005017
2004-02-15 21:58 syzop Note Edited: 0005016
2004-02-15 22:02 syzop Note Added: 0005018
2004-02-15 22:12 codemastr Note Added: 0005019
2004-02-15 22:59 syzop Note Added: 0005021
2004-03-05 17:48 codemastr Status new => resolved
2004-03-05 17:48 codemastr Resolution open => fixed
2004-03-05 17:48 codemastr Assigned To => codemastr
2004-03-05 17:48 codemastr Note Added: 0005307