View Issue Details

IDProjectCategoryView StatusLast Update
0002534unrealircdpublic2015-07-09 18:53
ReporterSirius Assigned Tosyzop  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.2.4 
Summary0002534: Snomasks and Flags in /WHOIS
DescriptionIsn't it a good idea to show flags for an oper in an /WHOIS?
Like this:

-
Sirius is CPT@Network-Admin.Chillingplace.tk * Biggy R.
Sirius is using modes +iowgraAsxNWqvtGpK +kcfFjveGnNqSsoJ
Sirius is using operflags +OaNrRDhgwGLKBZtvqHWXd
Sirius is connecting from *@212-127-204-30.cable.quicknet.nl 212.127.204.30
Sirius is a registered nick
Sirius on @#Opers #chillingplace
Sirius using chillingplace.cjb.net Chillingplace IRC Network
Sirius is a Network Administrator
Sirius is a Services Root Administrator
Sirius has been idle 3mins, signed on Wed May 25 15:12:51
Sirius End of /WHOIS list.
-
TagsNo tags attached.
3rd party modules

Activities

syzop

2005-05-25 10:14

administrator   ~0009981

Doesn't seem like a bad idea to me.
[Well, only show it to other ircops of course.]

Stealth

2005-05-25 19:01

reporter   ~0009991

Sounds fun... but what would the point be? Unreal already has umodes for all the levels, and if you wanted to know what an oper can do, just /stats o. If there is any reason you dont wan't to /stats o, it is probably because you are being sneaky and don't want people to know you are looking at that kinda info.

aquanight

2005-05-25 23:18

reporter   ~0009992

Last edited: 2005-05-25 23:23

Well, when you whois someone you're already taking the chance they're +W (as they are in this case) and can see that anyway...

The only problem is, when you do /stats O, how do you know which line to look at? Unless the operlogin was listed in /whois (an idea that was already turned down[1]) you might not know which line to look for (especially if you use *@* hosts for a large number of olines).

*edit*[1] Ok maybe not exactly turned down but you certainly would have to dig deep in the buglist to find it... 0002301 . */edit*

Sirius

2005-05-26 17:04

reporter   ~0010005

Opers can add and remove operflags. Not only by themselve, but also by other opers. Usermodes are completely different from operflags.
Operflags tell you what an oper can do and what he can't do.

w00t

2005-06-01 00:22

reporter   ~0010018

But it's not that simple.

For example, you have my often thrown-about example of flag k (global_kill as I recall) which is included in modes +oaAN but not +O. Unless Unreal seperated out all the priviledges somehow.. I can't really see how this would work without confusing people. Then you have the problem of what numeric to use, I believe client coders would just about shoot you guys for adding another numeric ;). (of course, RPL_TEXT might work.. but it probably would look odd on the client end.)

Really the current system of oper modes and oper flags is a bit vague at best. I know this is going to get me shot, but how about a system where you can specify exactly what permissions apply to a specific oper? (Right down to denying certain opers /stats c even, for example.) I realise that this would require some thought and I'll try throw some ideas about over the next few weeks about it - and yes, I realise that this probably won't happen even if it gets approved till like Unreal4 ;)

aquanight

2005-06-01 00:42

reporter   ~0010019

Mind telling me what seperating oper flags has anything to do with a line in /whois? We managed just fine with /stats O, and angrywolf's m_getinfo (I believe it displays the operflags)... so...

White_Magic

2005-06-06 08:14

reporter   ~0010046

i only see it being open to abuse and its pretty usless considering u can do /stats O
-

Bergee

2005-06-07 13:12

reporter   ~0010059

Errr, assuming it's only shown to other ircops as syzop says how do you imagine this is open to abuse? Not to mention that /stats O does not necessarily reflect the current flags on an oper if they've been changed in the conf for whatever reason since the oper last opered up.

codemastr

2005-06-07 23:05

reporter   ~0010065

[quote]I believe client coders would just about shoot you guys for adding another numeric ;).[/quote]
Well that's their problem, not ours.

White_Magic

2005-06-08 05:01

reporter   ~0010069

well..
1) what/why does a ircop have interest in what flags another has? (unless there is a problem like they cant do sumthing maybe they should) but theres Stats O to check for that..

if another ircop is checking out the other ircops flags then obviously , they are nosey, they r power hungry, or are not very trusting.

2) Sirius is CPT@Network-Admin.Chillingplace.tk
 
the Network-Admin Part should give a pretty big hint to what flags u will have and what u wont have... (the same with the other Vhosts)

3) after releaseing (from another bug post here) that umode +W is really usless, i take the same view on this, all this 1 extra numeric for what? something you can find in another command *a IRCOP Command* at that, isnt it good excerise, but in saying this, maybe if the coders added the login name as well as the flags it would be better, as its providing multiple information at once.
[quote]White_Magic has flags +iowghrAsTxWvtp Login Name: M4G|C[/quote]

alot of people paste there whois, well i do anyway, even my ip, another line to add to it i guess. ah well,

Stealth

2005-06-09 21:07

reporter   ~0010073

Maybe adding the flags to /trace?

aquanight

2007-05-23 22:04

reporter   ~0014216

*bump*

I think this might be handy, but would require eyes snomask be active, just like current umodes + snomasks numeric does. Do we have a handy numeric for this? Or will someone have to pick one from a hat?

Sirius

2007-05-24 03:54

reporter   ~0014217

I've made an mIRC scripting based IRCD and I use raw numeric 378 (the same as the "using modes" raw) for the operflags in the /whois.

I dno if thats a good idea? What numeric will Unreal use?

syzop

2015-07-09 18:53

administrator   ~0018437

With the new oper privilege system this wouldn't work anymore.

Issue History

Date Modified Username Field Change
2005-05-25 09:44 Sirius New Issue
2005-05-25 10:14 syzop Note Added: 0009981
2005-05-25 19:01 Stealth Note Added: 0009991
2005-05-25 23:18 aquanight Note Added: 0009992
2005-05-25 23:23 aquanight Note Edited: 0009992
2005-05-26 17:04 Sirius Note Added: 0010005
2005-06-01 00:22 w00t Note Added: 0010018
2005-06-01 00:42 aquanight Note Added: 0010019
2005-06-06 08:14 White_Magic Note Added: 0010046
2005-06-07 13:12 Bergee Note Added: 0010059
2005-06-07 23:05 codemastr Note Added: 0010065
2005-06-08 05:01 White_Magic Note Added: 0010069
2005-06-09 21:07 Stealth Note Added: 0010073
2007-04-27 04:09 stskeeps Status new => acknowledged
2007-05-23 22:04 aquanight Note Added: 0014216
2007-05-24 03:54 Sirius Note Added: 0014217
2015-07-09 18:53 syzop Note Added: 0018437
2015-07-09 18:53 syzop Status acknowledged => resolved
2015-07-09 18:53 syzop Resolution open => no change required
2015-07-09 18:53 syzop Assigned To => syzop