View Issue Details

IDProjectCategoryView StatusLast Update
0002723unrealircdpublic2020-09-27 19:57
ReporterTset Assigned Tosyzop  
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSLinux 
Product Version3.2.3 
Fixed in Version5.0.0 
Summary0002723: allow-userhost-change force-rejoin not done @ SVSMODE -xt by services
DescriptionWhen services/HostServ sets a vhost with CHGHOST a rejoin is forced.
However, when HostServ unsets vhost with SVSMODE -xt the vhost is correctly removed but a rejoin is not done.
Steps To Reproduce/hostserv on
# rejoin forced
/hostserv off
# no rejoin
Additional Informationservices used is anope 1.7.8
TagsNo tags attached.
3rd party modules

Activities

stskeeps

2007-04-27 05:07

reporter   ~0013805

Bump. Is this still an issue?

Tset

2009-06-06 22:00

reporter   ~0015864

It's still the same in 3.2.8.1 (anope 1.8.0).

katsklaw

2009-06-06 22:32

reporter   ~0015865

Last edited: 2009-06-07 10:24

probably a good idea to check SAMODE as well since it too can set -x.

[katsklaw@fbsd71 ~/Unreal3.2/src/modules]$ grep "rejoin_dojoinandmode" *
m_chghost.c: rejoin_dojoinandmode(acptr, did_parts);
m_chgident.c: rejoin_dojoinandmode(acptr, did_parts);
m_mode.c: rejoin_dojoinandmode(sptr, did_parts);
m_mode.c: rejoin_dojoinandmode(sptr, did_parts);
m_sethost.c: rejoin_dojoinandmode(sptr, did_parts);
m_setident.c: rejoin_dojoinandmode(sptr, did_parts);
m_vhost.c: rejoin_dojoinandmode(sptr, did_parts);

Seems SVSMODE and SAMODE are both missing it.

syzop

2020-09-27 19:57

administrator   ~0021772

Issue does not exist in 5.0.0, user is correctly "rejoin". It may have been fixed even before that in 4.x, not going to research that.. :)

Issue History

Date Modified Username Field Change
2005-12-22 11:55 Tset New Issue
2007-04-27 05:07 stskeeps Note Added: 0013805
2007-04-27 05:07 stskeeps Status new => feedback
2009-06-06 22:00 Tset Note Added: 0015864
2009-06-06 22:32 katsklaw Note Added: 0015865
2009-06-06 22:33 katsklaw Note Edited: 0015865
2009-06-06 22:35 katsklaw Note Edited: 0015865
2009-06-06 22:42 katsklaw Note Edited: 0015865
2009-06-06 22:43 katsklaw Note Edited: 0015865
2009-06-06 22:44 katsklaw Note Edited: 0015865
2009-06-07 10:24 katsklaw Note Edited: 0015865
2020-09-27 19:57 syzop Assigned To => syzop
2020-09-27 19:57 syzop Status feedback => resolved
2020-09-27 19:57 syzop Resolution open => fixed
2020-09-27 19:57 syzop Fixed in Version => 5.0.0
2020-09-27 19:57 syzop Note Added: 0021772