View Issue Details

IDProjectCategoryView StatusLast Update
0003335unrealircdpublic2019-10-14 15:56
ReporterStealthAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platform*OS*OS Version*
Product Version3.3-alpha0 
Target VersionFixed in Version4.2.0 
Summary0003335: Notice before bad password connect when password does not match allow::password
DescriptionIt would be nice to have a setting to send a notice to users when they fail to provide the proper connect password. Something that can be configurable in the conf. This would provide a way to allow private networks to tell someone trying to connect why they are not allowed on, or where to go to get help.

Conf setting such as set::badpass-notice

An example of what someone may put there is "This is a private network, and you must specify the proper password to connect. Please visit www.example.com/badpass.html for more info or to get help."
TagsNo tags attached.
3rd party modules

Activities

Bricker

2007-05-12 21:18

reporter   ~0014105

I like it. There could be downfalls that users should know, that such people knowing that a certain password is required will cause some people to try harder etc. But it would be a nice option for users.

+1

syzop

2019-10-14 15:56

administrator   ~0020989

Since 4.x (I forgot which version) the rejection error messages are configurable.
They are here: https://www.unrealircd.org/docs/Set_block#set::reject-message
Note that with 5.x we have a slightly different behavior for wrong password, as it will continue the other allow blocks.

Old bug.. so with the knowledge and features of 12 years later:
Also, for the usecase you describe: even better would be to use SASL and authprompt module, which allows authenticating against specific accounts and asks to enter a password interactively.

Issue History

Date Modified Username Field Change
2007-05-12 20:43 Stealth New Issue
2007-05-12 21:18 Bricker Note Added: 0014105
2007-05-13 07:50 stskeeps Status new => feedback
2019-10-14 15:56 syzop Assigned To => syzop
2019-10-14 15:56 syzop Status feedback => resolved
2019-10-14 15:56 syzop Resolution open => fixed
2019-10-14 15:56 syzop Fixed in Version => 4.2.0
2019-10-14 15:56 syzop Note Added: 0020989