View Issue Details

IDProjectCategoryView StatusLast Update
0003375unrealircdpublic2019-10-14 18:48
ReportertabrisnetAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinux/x86OSDebian LinuxOS Versiontesting
Product Version3.2.6 
Target VersionFixed in Version5.0.0-beta1 
Summary0003375: oper-only-stats whitelist instead of blacklist
DescriptionI'd like to see something that does the opposite of oper-only-stats, thus I can whitelist particular stats for users to read. I don't want to blacklist only some stats and then have more stats added and have an infoleak.
I think it would be more useful to have 'allow-user-stats' or similar, so I can allow 'stats u' (and maybe others as well)
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0005109 resolvedsyzop Whitelist stats flags (reverse of oper-only-stats) 

Activities

Shining Phoenix

2007-06-01 19:32

reporter   ~0014257

+1 to tabrisnet

Stealth

2007-06-02 01:03

reporter   ~0014258

I like this idea, it makes more sense than what Unreal has. I'd like to see oper-only-stats replaced by this.

syzop

2019-10-14 15:51

administrator   ~0020986

0005109 is a duplicate of this. Normally I close the newer one but that one has more discussion, so I'm closing this one instead.

syzop

2019-10-14 18:48

administrator   ~0021039

commit d0b9b02d0506555ce56b5fd6ffbd7395f889f75e (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Oct 14 18:46:14 2019 +0200

    We no longer use a blacklist for stats (set::oper-only-stats) but
    have a whitelist now instead (set::allow-user-stats).
    Suggested by tabrisnet, The_Myth and Jobe in
    https://bugs.unrealircd.org/view.php?id=3375 and
    https://bugs.unrealircd.org/view.php?id=5109

Issue History

Date Modified Username Field Change
2007-06-01 11:36 tabrisnet New Issue
2007-06-01 19:32 Shining Phoenix Note Added: 0014257
2007-06-02 01:03 Stealth Note Added: 0014258
2007-06-04 10:50 stskeeps Status new => acknowledged
2019-10-14 15:51 syzop Relationship added duplicate of 0005109
2019-10-14 15:51 syzop Assigned To => syzop
2019-10-14 15:51 syzop Status acknowledged => closed
2019-10-14 15:51 syzop Resolution open => duplicate
2019-10-14 15:51 syzop Note Added: 0020986
2019-10-14 18:48 syzop Status closed => resolved
2019-10-14 18:48 syzop Fixed in Version => 5.0.0-beta1
2019-10-14 18:48 syzop Note Added: 0021039