View Issue Details

IDProjectCategoryView StatusLast Update
0003818unrealircdpublic2019-10-14 15:46
ReportergoldenwolfAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformi386OSFreeBSDOS Version7.1
Product Version3.2.8 
Target VersionFixed in Version4.2.4 
Summary0003818: Ability to disallow new connections till further notice
DescriptionTemporarily disallow connections n dire times.
Additional InformationI think it would be a great idea to have UnrealIRCD temporarily not allow incoming connections till further notice.
Something like /pause , could be useful in many different ways such as during botnets/floods/netsplits.
Temporarily stopping connections can decrease the load servers and services have to take after net splits.
This could also be a great opportunity to further use the hub/leaf directive.
Ex: This could be all controlled through hub, meaning hub has the authority to pause connections on all/selected servers if possible.
TagsNo tags attached.
3rd party modules

Activities

Stealth

2009-07-23 17:34

reporter   ~0015883

I do not know if this should be included as a core feature to Unreal, but rather a module instead.

JumpServer by Syzop already provides the ability to close a server to new connections, and redirects users to another server (if their client supports it)

What does everyone else think?

syzop

2019-10-14 15:46

administrator   ~0020982

We now have reputation and connthrottle to do this automatically since 4.2.4 (actually, sightly earlier, but 4.2.4 has a correct implementation). I think that's sufficient.

Issue History

Date Modified Username Field Change
2009-02-08 01:46 goldenwolf New Issue
2009-07-23 17:34 Stealth Note Added: 0015883
2009-07-23 17:34 Stealth Status new => feedback
2019-10-14 15:46 syzop Assigned To => syzop
2019-10-14 15:46 syzop Status feedback => resolved
2019-10-14 15:46 syzop Resolution open => fixed
2019-10-14 15:46 syzop Fixed in Version => 4.2.4
2019-10-14 15:46 syzop Note Added: 0020982