View Issue Details

IDProjectCategoryView StatusLast Update
0004169unrealircdpublic2015-10-26 11:07
ReporterwargAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSWIN32OS Version
Product Version3.2.10 
Target VersionFixed in Version4.0.0-rc2 
Summary0004169: Undefined variable used in makefile.win32
DescriptionOn line 281-282 for ./UNREAL.EXE: in makefile.win32:

./UNREAL.EXE: SRC/UNREAL.OBJ SRC/WIN32/UNREAL.RES
    $(LINK) $(DBGLFLAGST) advapi32.lib src/unreal.obj src/win32/unreal.res

There is no "DBGLFLAGST" defined.

Also, on line 155-156 for CFLAGS and 157-258 for CFLAGSST in makefile.win32:

CFLAGS=$(DBGCFLAG) $(TRE_INC) $(CARES_INC) $(LIBCURL_INC) $(ZLIB_INC) $(OPENSSL_INC) /J /I ./INCLUDE /I ./INCLUDE/WIN32/ARES /Fosrc/ /nologo \
 $(ZIPCFLAGS) $(CURLCFLAGS) $(FD_SETSIZE) $(SSLCFLAGS) $(NS_ADDRESS) /D NOSPOOF=1 /c /D _CRT_SECURE_NO_DEPRECATE /D _CRT_NONSTDC_NO_DEPRECATE /D _USE_32BIT_TIME_T

I don't believe NS_ADDRESS is used.
Additional InformationRegarding DBGLFLAGST, this means unreal.exe is being linked without any LFLAGS. Perhaps this is intended and should be removed. If not, then perhaps changed to DBGLFLAG (DBGLFLAG=/DEBUG).
TagsNo tags attached.
3rd party modules

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2013-02-12 16:36 warg New Issue
2013-02-19 22:49 syzop Status new => acknowledged
2015-10-26 11:06 syzop Status acknowledged => resolved
2015-10-26 11:06 syzop Fixed in Version => 4.0.0-rc2
2015-10-26 11:06 syzop Resolution open => fixed
2015-10-26 11:06 syzop Assigned To => syzop