View Issue Details

IDProjectCategoryView StatusLast Update
0004230unrealircdpublic2020-04-12 17:46
ReporterAnha26 Assigned Tosyzop  
PrioritynormalSeveritytweakReproducibilitysometimes
Status resolvedResolutionfixed 
Platform*NIXOSUbuntu 
Product Version3.2.10.1 
Fixed in Version5.0.0 
Summary0004230: Ident: Doesn't accept underscore (valid in RFC!)
DescriptionAs summary says; You can't use underscore as ident (nick!ident@host), even though RFC allows it.

 - Works on some servers, I don't know how though!

Works on: chat.frostwire.com:6667
Fails on: chat.gecero.net:6667
Steps To ReproduceChange ident to e.g. me_you
Additional InformationTried without modules, as well as with.
Made no difference!
Tagsbug, host, ident, nick, rfc, ubuntu, username
3rd party modulesantimoon, m_regexcept, m_rmtkl, and textban

Activities

katsklaw

2013-08-24 17:36

reporter   ~0017757

Technically you are correct. However, there is a difference between theory and practice as well as a difference between what's allowed and what's forbidden, there is a gap between the 2 and special characters falls in that median.

You will find that in many cases Unix systems also will not allow the _ or any other special character that is not expressly prohibited by RFC 1413. Most of which take a conservative approach and simply limit usernames to NAME_REGEX, which by default is set to: ^[a-z][-a-z0-9]*\$

In short, just because something is not explicitly forbidden, doesn't mean it *must* be allowed.

My personal opinion is that Unreal IRCd too should take a conservative stance and disallow special characters as well as there is no harm in it, nor is there any advantage of allowing user_name as opposed to username.

Anha26

2013-08-24 18:03

reporter   ~0017758

True, but I've seen some who have used slash in their vhost (after @)...
And in my honest opinion, it should be up to the server admin to decide which is permitted.
Also for usernames, e.g. only a-z A-Z 0-9 and minus is permitted, instead of allowing à and á etc.

syzop

2015-08-08 17:14

administrator   ~0018636

I suppose underscore would be fine, odd that it isnt included. Don't think we should go crazy with accepting other stuff though ;).

syzop

2020-04-12 17:45

administrator   ~0021456

Last edited: 2020-04-12 17:46

View 3 revisions

This was fixed in 5.0.0 back in 2019. The ident can now contain the same characters as non-idents (so username provided via the "USER" command and "SETNAME"), this includes underscore.

Issue History

Date Modified Username Field Change
2013-08-03 18:15 Anha26 New Issue
2013-08-03 18:16 Anha26 Tag Attached: bug
2013-08-03 18:16 Anha26 Tag Attached: host
2013-08-03 18:16 Anha26 Tag Attached: ident
2013-08-03 18:16 Anha26 Tag Attached: nick
2013-08-03 18:16 Anha26 Tag Attached: rfc
2013-08-03 18:16 Anha26 Tag Attached: ubuntu
2013-08-03 18:16 Anha26 Tag Attached: username
2013-08-15 21:48 syzop Priority high => normal
2013-08-24 17:36 katsklaw Note Added: 0017757
2013-08-24 18:03 Anha26 Note Added: 0017758
2014-03-14 01:14 peterkingalexander Issue cloned: 0004287
2015-08-08 17:14 syzop Note Added: 0018636
2015-08-08 17:14 syzop Assigned To => syzop
2015-08-08 17:14 syzop Status new => acknowledged
2020-04-12 17:45 syzop Status acknowledged => resolved
2020-04-12 17:45 syzop Resolution open => fixed
2020-04-12 17:45 syzop Fixed in Version => 5.0.0
2020-04-12 17:45 syzop Note Added: 0021456
2020-04-12 17:46 syzop Note Edited: 0021456 View Revisions
2020-04-12 17:46 syzop Note Edited: 0021456 View Revisions