View Issue Details

IDProjectCategoryView StatusLast Update
0004298unrealircdpublic2014-03-14 01:14
ReporterpeterkingalexanderAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformGNU/LinuxOSGNU/Linux DebianOS VersionDebian 6.0.7
Product Version3.2.10.1 
Target VersionFixed in Version 
Summary0004298: When I start Unrealircd, it reports me an error that is just the starting message. However, the server starts though.
DescriptionStarting UnrealIRCd
 _ _ _ ___________ _____ _
| | | | | |_ _| ___ \/ __ \ | |
| | | |_ __ _ __ ___ __ _| | | | | |_/ /| / \/ __| |
| | | | '_ \| '__/ _ \/ _` | | | | | / | | / _` |
| |_| | | | | | | __/ (_| | |_| |_| |\ \ | \__/\ (_| |
 \___/|_| |_|_| \___|\__,_|_|\___/\_| \_| \____/\__,_|
                           v3.2.10.1
                     using TRE 0.8.0 (BSD)
                     using OpenSSL 0.9.8o 01 Jun 2010

* Loading IRCd configuration ..
* Configuration loaded without any problems ..
* Loading tunefile..
* Initializing SSL.
* Dynamic configuration initialized .. booting IRCd.
---------------------------------------------------------------------
Possible error encountered (IRCd seemingly not started)
=====================================================
Check above for possible errors, and this output of
ircd.log. If you cannot solve the problem, read
Unreal.nfo on where to get support
=====================================================
[Sat Jun 22 03:45:16 2013] - UnrealIRCd started.
Steps To ReproduceThis "bug" happens everytime I start the server.
TagsNo tags attached.
3rd party modules

Activities

syzop

2013-06-22 13:01

administrator   ~0018082

Ok, so if I understand correctly it's a false warning/error?

Anything in 'ircd.log' that indicates an error?

syzop

2013-06-22 13:04

administrator   ~0018083

The ./unreal script waits only 1 second for the IRCd to boot (well, actually 1 second after the fork), it might be wise to wait a little bit longer.. like if the pidfile isn't found after 1 second, then wait another x seconds.

Miocastoor

2013-06-25 18:51

reporter   ~0018084

Hum, the problem is now resolved.

In the ./unreal script, $PIDFILE points to an "ircd.pid" file and I had called my pidfile "unrealircd.pid" in the config file... So it couldn't find the pid file because it had not the original name. I renamed the pid file as "ircd.pid" in the configuration, and it just resolved the problem.

Sorry for the inconvenience!

syzop

2013-06-25 22:41

administrator   ~0018085

ok, thanks for reporting back to us!

you were the first to mention this problem, so I was already wondering.. ;p

Issue History

Date Modified Username Field Change
2014-03-14 01:14 peterkingalexander New Issue
2014-03-14 01:14 peterkingalexander Issue generated from: 0004223