View Issue Details

IDProjectCategoryView StatusLast Update
0004372unrealircdpublic2019-01-28 15:48
ReporterAmiga600Assigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.4-alpha4 
Target VersionFixed in Version4.2.2-rc1 
Summary0004372: Optional nick!ident@host Display in Topic/Ban/Invite/Exception Lists
DescriptionJust an idea to create an optional config parameter for nick!ident@host in Channel Topics/Ban/Invite/Exception Lists

set {
   showidenthostdata [on/off];
}

If that setting was "on", it would then show the full nick!ident@host in Topic/Ban/Invite/Exception List(s)

Topic: nick #channel nick!ident@host.net 1435500492

Ban/invite/exception: nick #channel ~n:*!*@* nick!ident@host.net 1413660316
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-01-28 15:48

administrator   ~0020468

Added in 4.2.2, thanks for the report.

commit d085fb09c12e8e1d318b2c6a65605c028d8020e4 (HEAD -> unreal42, origin/unreal42)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Jan 28 15:41:44 2019 +0100

    Three new config items to make topic and ban setter nick!user@host and
    to control synchronization of the +beI setter across server links
    (that is, the feature just introduced one commit ago):
    set {
         topic-setter [nick|nick-user-host]; /* nick = default */
         ban-setter [nick|nick-user-host]; /* nick = default */
         ban-setter-sync [yes|no]; /* yes = default */
    };
    This also means that --with-topicisnuhost / TOPIC_NICK_IS_NUHOST
    is now removed, since this now goes via set::topic-setter.
    
    Also, moved the "first" PROTOCTL from include/common.h to send_proto()
    in src/s_serv.c so the bunch of PROTOCTL lines is all in one place
    (and so I could conditionally send SJSBY).
    Ok, it's not entirely all in one place, PROTOCTL EAUTH is still sent
    at another place (early, duh), but still..

Issue History

Date Modified Username Field Change
2015-06-28 16:20 Amiga600 New Issue
2019-01-28 15:48 syzop Assigned To => syzop
2019-01-28 15:48 syzop Status new => resolved
2019-01-28 15:48 syzop Resolution open => fixed
2019-01-28 15:48 syzop Fixed in Version => 4.2.2-rc1
2019-01-28 15:48 syzop Note Added: 0020468