View Issue Details

IDProjectCategoryView StatusLast Update
0004925unrealircdpublic2019-10-14 14:54
ReporteracidvegasAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0.0-alpha3 
Summary0004925: Delay for /LIST and Private Messages
DescriptionThe official unrealircd IRC has been getting attacked by bots, as-well as many people who run an unrealircd daemon. Most of the bots will crawl across channels from the /list output and then PM spam all the users on the channels making a large amount of query windows open and cause a bunch of notifications.

A simple delay that can be configured in the config to make suers wait x amount of time before they can do /list or PM would mitigate this greatly.

I know 3rd party modules exist, but these are not official and not everyone even knows these modules exist.
TagsNo tags attached.
3rd party modules

Activities

syzop

2017-04-04 07:25

administrator   ~0019733

I believe there is indeed some 3rd party module for that (/LIST anyway). I wouldn't mind seeing it integrated in UnrealIRCd.

syzop

2018-12-28 14:24

administrator   ~0020430

bump

syzop

2019-10-14 14:54

administrator   ~0020962

Since 5.0.0-alpha3 (or 2?) we have this.
Documentation is available at: https://www.unrealircd.org/docs/Set_block#set::restrict-commands

The example configuration ships with the following: https://github.com/unrealircd/unrealircd/blob/unreal50/doc/conf/examples/example.conf#L494-L521 (this last may be out of date if you visit months later)


Issue History

Date Modified Username Field Change
2017-04-04 02:38 acidvegas New Issue
2017-04-04 07:25 syzop Assigned To => syzop
2017-04-04 07:25 syzop Status new => acknowledged
2017-04-04 07:25 syzop Note Added: 0019733
2018-12-28 14:24 syzop Note Added: 0020430
2019-10-14 14:54 syzop Status acknowledged => resolved
2019-10-14 14:54 syzop Resolution open => fixed
2019-10-14 14:54 syzop Fixed in Version => 5.0.0-alpha3
2019-10-14 14:54 syzop Note Added: 0020962