View Issue Details

IDProjectCategoryView StatusLast Update
0005109unrealpublic2019-10-14 18:48
ReporterThe_MythAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version18.04 LTS
Product Version4.0.18 
Target Version4.2.4Fixed in Version5.0.0-beta1 
Summary0005109: Whitelist stats flags (reverse of oper-only-stats)
DescriptionCurrently the "set::oper-only-stats" is set to ALL ("*"), which means we need to tweak it to allow users to use "/stats j" (to display the list of official channels) an that's not an easy task.
Would be nice to have something like "set::user-only-stats", so we would put in there the stats we want to allow users to see.
Any thoughts about this?
Tagsconf, ircd
3rd party modules

Relationships

has duplicate 0003375 resolvedsyzop oper-only-stats whitelist instead of blacklist 

Activities

syzop

2019-04-22 21:02

administrator   ~0020599

set::user-only-stats would be a misnomer though, since it is not only for users, but also for opers.
Perhaps something like: set { oper-only-stats "!abc"; };
Nah.. we'll think of something... but not for next release :D

=> 4.2.4

The_Myth

2019-04-22 22:53

reporter   ~0020601

Or something like set::user-avail(able)-stats?
For me, => 4.2.4 is fine. Is just that's a easier way to make some info publicly available while protecting other.

Cheers

The_Myth

2019-04-22 22:58

reporter   ~0020602

Or as the current title kinda suggest, set::whitelist-stats "flags"

syzop

2019-10-14 15:51

administrator   ~0020985

Turns out this is a duplicate of 0003375, but since this one has more discussion I'll close 0003375.

syzop

2019-10-14 18:48

administrator   ~0021038

commit d0b9b02d0506555ce56b5fd6ffbd7395f889f75e (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Oct 14 18:46:14 2019 +0200

    We no longer use a blacklist for stats (set::oper-only-stats) but
    have a whitelist now instead (set::allow-user-stats).
    Suggested by tabrisnet, The_Myth and Jobe in
    https://bugs.unrealircd.org/view.php?id=3375 and
    https://bugs.unrealircd.org/view.php?id=5109

Issue History

Date Modified Username Field Change
2018-06-27 16:35 The_Myth New Issue
2018-06-27 16:35 The_Myth Tag Attached: conf
2018-06-27 16:35 The_Myth Tag Attached: ircd
2019-04-22 21:00 syzop Summary [Feature Request] Option to allow override of "oper-only-stats" option => Whitelist stats flags (reverse of oper-only-stats)
2019-04-22 21:02 syzop Note Added: 0020599
2019-04-22 21:03 syzop Status new => acknowledged
2019-04-22 21:03 syzop Target Version => 4.2.4
2019-04-22 22:53 The_Myth Note Added: 0020601
2019-04-22 22:58 The_Myth Note Added: 0020602
2019-10-14 15:51 syzop Note Added: 0020985
2019-10-14 15:51 syzop Relationship added has duplicate 0003375
2019-10-14 18:48 syzop Assigned To => syzop
2019-10-14 18:48 syzop Status acknowledged => resolved
2019-10-14 18:48 syzop Resolution open => fixed
2019-10-14 18:48 syzop Fixed in Version => 5.0.0-beta1
2019-10-14 18:48 syzop Note Added: 0021038