View Issue Details

IDProjectCategoryView StatusLast Update
0005197unrealircdpublic2019-11-20 17:22
ReporterargvxAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.2.1 
Target VersionFixed in Version5.0.0-alpha2 
Summary0005197: configure fails to detect openssl
DescriptionWhen using openssl in /opt for example, configure fails to detect it due to missing libraries in it's checking functions (-lrt or -ldl or -lpthread) on Debian, howewer, this seems to be not an issue on Gentoo for some reason.
TagsNo tags attached.
3rd party modules

Activities

westor

2019-01-25 12:13

reporter   ~0020463

same problem if try to install it on clean ubuntu 18.04 , i had to re-install the openssl and then re-configure in order to detect it.

syzop

2019-01-27 14:49

administrator   ~0020466

westor: you mean the openssl package? or did you compile openssl from source and put it in /opt (or some other non-standard directory)?
I only ask because the former is likely to be a different issue than the latter.
What error did you get exactly?

syzop

2019-11-20 17:22

administrator   ~0021108

I think this issue is fixed on U5. At least 'i' added support for -lrt and such in the tests so that seems very related.

syzop

2019-11-20 17:22

administrator   ~0021109

Oh the bug report is from him, then it was fixed I guess :D

Issue History

Date Modified Username Field Change
2019-01-25 11:27 argvx New Issue
2019-01-25 12:13 westor Note Added: 0020463
2019-01-27 14:49 syzop Note Added: 0020466
2019-11-20 17:22 syzop Note Added: 0021108
2019-11-20 17:22 syzop Assigned To => syzop
2019-11-20 17:22 syzop Status new => closed
2019-11-20 17:22 syzop Resolution open => fixed
2019-11-20 17:22 syzop Fixed in Version => 5.0.0-alpha2
2019-11-20 17:22 syzop Note Added: 0021109
2019-11-20 17:22 syzop Status closed => resolved