View Issue Details

IDProjectCategoryView StatusLast Update
0005263unrealircdpublic2019-05-10 13:49
ReporterKoraggAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.2.3 
Target VersionFixed in Version4.2.4 
Summary0005263: CAP subcommands are case sensitive
DescriptionIt appears that CAP subcommands such as LS and REQ are case sensitive as /cap ls gives back invalid subcommand yet /cap LS gives the usual response. This appears to happen for req vs REQ as well thus all commands are likely effected. Tested and confirmed on UnrealIRCd versions 4.0.23 and 4.0.17 though it most likely effects all hat support the CAP command.
Steps To ReproduceRun any CAP subcommand in lowercase and observe the response CAP invalid subcommand
Run any CAP subcommand in UPPERCASE and observe the expected responses/behaviour.
Additional InformationThis likely occurs on all UnrealIRCd versions which implement the CAP command.
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-05-10 09:01

administrator   ~0020650

The CAP specification does not specify if the command should be
case sensitive or case insensitive, only that the capability names
are case sensitive.
Since in the IRC world generally everything is case insensitive,
except modes and who flags come to mind.. and some message tags,
the code was now changed for the command to be case insensitive.

syzop

2019-05-10 09:01

administrator   ~0020651

commit 9f8e73dca74adb0bae09bbc4d0aff61674085b2c (HEAD -> unreal42, origin/unreal42, origin/HEAD)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Fri May 10 08:57:16 2019 +0200

    Make CAP commands case sensitive.
    Suggested by Koragg in https://bugs.unrealircd.org/view.php?id=5263

syzop

2019-05-10 13:49

administrator   ~0020652

I made a typo in the commit message, of course I mean "Make CAP commands case INsensitive" ;)

Issue History

Date Modified Username Field Change
2019-05-06 01:37 Koragg New Issue
2019-05-07 07:29 syzop Status new => confirmed
2019-05-10 09:01 syzop Note Added: 0020650
2019-05-10 09:01 syzop Assigned To => syzop
2019-05-10 09:01 syzop Status confirmed => resolved
2019-05-10 09:01 syzop Resolution open => fixed
2019-05-10 09:01 syzop Fixed in Version => 4.2.4
2019-05-10 09:01 syzop Note Added: 0020651
2019-05-10 13:49 syzop Note Added: 0020652