View Issue Details

IDProjectCategoryView StatusLast Update
0005268unrealircdpublic2019-10-14 14:50
Reportervectr0nAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0.0-alpha3 
Summary0005268: Include KLines/Zlines In exempt tkl block
DescriptionWould be nice if klines and zlines would be included in the exempt tkl block as they are not currently.
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-05-10 08:24

administrator   ~0020648

Indeed, right now it's just plain confusing. And almost probably everyone who adds 'except tkl' should add (and maybe does) 'except ban' as well.

Also, as discussed, we probably should just rename the thing to 'except ban', which is more descriptive. With some backwards compatibility or warnings and such...

syzop

2019-10-14 14:50

administrator   ~0020960

Since 5.0.0-alpha we have only "except ban" which applies to all by default, but you can modify the type. "except tkl" no longer exists. This way it's way more clear...
See https://www.unrealircd.org/docs/Except_ban_block#UnrealIRCd_5 for documentation

Issue History

Date Modified Username Field Change
2019-05-10 08:12 vectr0n New Issue
2019-05-10 08:24 syzop Note Added: 0020648
2019-10-14 14:50 syzop Assigned To => syzop
2019-10-14 14:50 syzop Status new => resolved
2019-10-14 14:50 syzop Resolution open => fixed
2019-10-14 14:50 syzop Fixed in Version => 5.0.0-alpha3
2019-10-14 14:50 syzop Note Added: 0020960