View Issue Details

IDProjectCategoryView StatusLast Update
0005273unrealircdpublic2019-12-30 17:57
ReporterwestorAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.2.3 
Target VersionFixed in Version5.0.1 
Summary0005273: UnrealIRCD doesn't let O-Line staff members to remove a channel mode from MLOCK if services are down
DescriptionHello,

I saw that when there are some certain channel modes in services locked (tested on Anope 2.0.6 only) and services go down, then the ircd doesn't let O-Line staff with 'override' or with 'samode' to remove any of services MLOCK and returns an raw error.

I think O-Lines should bypass that with 'override' or with 'samode' or with both.

Raw Error:

-> 12/???/2019 16:22:56 - MODE #dragondyce -P
<- 12/???/2019 16:22:56 - :IRC.DragonDyce.Net 742 westor #dragondyce P ntCPTVciKlQSk :MODE cannot be set due to channel having an active MLOCK restriction policy
-> 12/???/2019 16:22:57 - samode #dragondyce -P
<- 12/???/2019 16:22:57 - :IRC.DragonDyce.Net 742 westor #dragondyce P ntCPTVciKlQSk :MODE cannot be set due to channel having an active MLOCK restriction policy

- Thanks!
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-05-12 17:06

administrator   ~0020661

I agree, I think opers (with sufficient privileges) should be able to do this. When services are down, for sure. Otherwise, when services are online, not so sure... hm.

syzop

2019-12-30 17:57

administrator   ~0021178

Done for 5.0.1, thanks for the suggestion:

commit c789ac6abef27099f61a2ea9c7eef1c597f73dd3
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Dec 30 17:52:22 2019 +0100

    Add channel:override:mlock operclass permission which allows overriding
    MLOCK restrictions when services are down (set::services-server).
    Suggested by westor in https://bugs.unrealircd.org/view.php?id=5273
    By default all opers with the *-with-override privilege have this,
    which sounds OK to me.

Issue History

Date Modified Username Field Change
2019-05-12 15:24 westor New Issue
2019-05-12 17:06 syzop Assigned To => syzop
2019-05-12 17:06 syzop Status new => acknowledged
2019-05-12 17:06 syzop Note Added: 0020661
2019-12-30 17:50 syzop Status acknowledged => assigned
2019-12-30 17:57 syzop Status assigned => resolved
2019-12-30 17:57 syzop Resolution open => fixed
2019-12-30 17:57 syzop Fixed in Version => 5.0.1
2019-12-30 17:57 syzop Note Added: 0021178