View Issue Details

IDProjectCategoryView StatusLast Update
0005285unrealircdpublic2019-08-18 15:17
ReportersyzopAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0.0-alpha1 
Summary0005285: U5: Rename SSL to TLS
DescriptionIdea/ discussion:
src/ssl.c -> src/tls.c
set::ssl to set::tls
::ssl-options to ::tls-options
and so on and so on......

I would have to think about this... if I really want that...
If anything, it should certainly be backwards-compatible I think, so existing users are not bothered by having to change their set::ssl and ::ssl-options block.
TagsNo tags attached.
3rd party modules

Relationships

child of 0005279 acknowledged UnrealIRCd 5 master tracking issue 

Activities

syzop

2019-08-13 17:18

administrator   ~0020813

This is more or less done now.

I use the tls options, eg set::tls, in the examples etc. etc. but not yet in the wiki documentation... simply because that refers to both U4 and U5 atm.
That also means that we can change that documentation at the earliest by January 2021. Great.

Ah well, not terribly important, this, anyway.

Issue History

Date Modified Username Field Change
2019-05-18 14:13 syzop New Issue
2019-05-18 14:13 syzop Status new => feedback
2019-05-18 14:13 syzop Relationship added child of 0005279
2019-08-13 17:18 syzop Assigned To => syzop
2019-08-13 17:18 syzop Status feedback => resolved
2019-08-13 17:18 syzop Resolution open => fixed
2019-08-13 17:18 syzop Fixed in Version => 5.0.0-alpha1
2019-08-13 17:18 syzop Note Added: 0020813
2019-08-18 15:17 syzop View Status private => public