View Issue Details

IDProjectCategoryView StatusLast Update
0005321unrealircdpublic2019-10-06 08:00
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0.0-alpha4 
Summary0005321: U5: cleanups
Descriptionvarious cleanups:

hash stuff -> already in other ticket

scache -> this looks old.. maybe use something better or newer which has reference counts? if we want this at all... that is.
TagsNo tags attached.
3rd party modules

Relationships

child of 0005279 acknowledged UnrealIRCd 5 master tracking issue 

Activities

syzop

2019-07-17 17:39

administrator   ~0020787

Notes, before I forget:

----
why on earth does DelListItem iterate the list??
--
force 'make clean' if ./Config was run << done
---
i think for spamfilter entries we shouldn't (re-)use the 'usermask', 'hostmask' and such, this is too confusing, so move this to the .spamf fields :)
does cost some minor memory, but there are only few spamfilters on a server (<100, <1000 for sure).
----

syzop

2019-08-17 16:54

administrator   ~0020818

Last edited: 2019-08-18 16:13

View 2 revisions

Only the spamfilter stuff from last comment is not done yet. Still a good idea, though.
Oh yeah, and have a look at scache.. hm.

syzop

2019-08-31 15:36

administrator   ~0020864

The cleanup with regards to spamfilter entries mentioned above has been done. It was part of a major TKL cleanup that I just did in https://github.com/unrealircd/unrealircd/commit/8a6c84876e2b517865a27c13da2153e130aaa92d
I expected some major bugs, but the test framework is happy and things seem so sync nicely with U5--U5. I'm sure more testing will reveal some issues and U4--U5 definitely needs to be tested as well, since that could be a problem.

syzop

2019-10-06 08:00

administrator   ~0020939

Last edited: 2019-10-06 08:00

View 2 revisions

Of course I will never be done with cleanups, but I'm done with this item for it after having done massive cleanups in U5 :D

Issue History

Date Modified Username Field Change
2019-06-22 18:01 syzop New Issue
2019-06-23 09:05 syzop Relationship added child of 0005279
2019-07-17 17:39 syzop Note Added: 0020787
2019-08-17 16:54 syzop Note Added: 0020818
2019-08-17 16:54 syzop Status new => acknowledged
2019-08-18 15:17 syzop View Status private => public
2019-08-18 16:13 syzop Note Edited: 0020818 View Revisions
2019-08-31 15:36 syzop Note Added: 0020864
2019-10-06 08:00 syzop Assigned To => syzop
2019-10-06 08:00 syzop Status acknowledged => resolved
2019-10-06 08:00 syzop Resolution open => fixed
2019-10-06 08:00 syzop Fixed in Version => 5.0.0-alpha4
2019-10-06 08:00 syzop Note Added: 0020939
2019-10-06 08:00 syzop Note Edited: 0020939 View Revisions