View Issue Details

IDProjectCategoryView StatusLast Update
0005340unrealircdpublic2019-09-09 20:37
ReporterGottemAssigned ToGottem 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target Version5.0.0-alpha1Fixed in Version 
Summary0005340: Port m_rmtkl
DescriptionI'd swear we had a conversation about it, but I can't actually seem to find it. ;_;

If I remember correctly, the most important bit was:
Currently the format is /rmtkl type user@host [comment] [-skipperm] [-silent]
But Syzop suggested to keep it consistent with gline etc, so /rmtkl user@host type ..........

The 'type' field can be any combination of: K, z, G, Z, s, F and *
These correspond to K:Line, (local) Z:Line, G:Line, Global Z:Line, (global) Shun and (global) Spamfilter (asterisk includes every type besides F)

Also, maybe remove the calls to TKL_DEL hooks since I originally used em there to make sure m_storetkl had an up-to-date DB.
TagsNo tags attached.
3rd party modules

Relationships

child of 0005282 assignedGottem Gottem's todo list yo 

Activities

syzop

2019-08-18 15:34

administrator   ~0020825

I will double check some stuff (also due to the crash) and if it's ok this can be closed :)

Gottem

2019-09-09 20:37

developer   ~0020880

Since you already made changes to the module, I'm assuming your double check is done. :D There's also a separate bug for the rmtkl crash (#5344) so I think we can go ahead and resolve this particular issue. =]

Issue History

Date Modified Username Field Change
2019-07-24 19:29 Gottem New Issue
2019-07-24 19:29 Gottem Status new => assigned
2019-07-24 19:29 Gottem Assigned To => Gottem
2019-07-24 19:29 Gottem Issue generated from: 0005282
2019-07-24 19:29 Gottem Relationship added child of 0005282
2019-08-10 21:58 Gottem Status assigned => has patch
2019-08-18 15:17 syzop View Status private => public
2019-08-18 15:34 syzop Note Added: 0020825
2019-09-09 20:37 Gottem Note Added: 0020880
2019-09-09 20:37 Gottem Status has patch => resolved
2019-09-09 20:37 Gottem Resolution open => fixed