View Issue Details

IDProjectCategoryView StatusLast Update
0005413unrealircdpublic2019-10-09 21:05
ReporterwestorAssigned ToGottem 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.0-alpha2 
Target VersionFixed in Version5.0.0-alpha4 
Summary0005413: Change restrict-commands server notice message into a raw 421
DescriptionHello,

I tried the "restrict-commands" module with "disable" option, it seems that this module when a command is restricted (disabled) then the server is sending a server notice that
saying that this command is restricted, this causing some clients to break.

Something similar like restrict-commands module exists and in other ircds that their method is not to send server notice but 421 raw so the client can determine that this command doesn't exist in result to not taking actions.

It will be nice for restrict-commands to follow this way rather sending a server notice thought because it breaking clients features that working with some irc commands.

- Thanks!
TagsNo tags attached.
3rd party modules

Relationships

child of 0005282 resolvedGottem Gottem's todo list yo 

Activities

Gottem

2019-09-18 19:54

developer   ~0020902

As Syzop also mentioned on IRC, many clients still break even with the raw 421. :D Even so, changing it to that is fine by me. I just went with a simple notice because all the sane clients check what/how the server responds anyways.

westor

2019-09-20 21:18

reporter   ~0020903

I personally like the server notice instead of the raw reply, but clients developers here disagree with me, i had a conversation with 2 of the most updated irc clients these days and they said that for them is the best way to add a raw reply rather a server notice, so it would appreciate if you can change that so they will not start some of the IRC commands progress if they get 421 raw reply.

- Thanks for understanding..

Gottem

2019-10-09 21:05

developer   ~0020948

I could've sworn I added this as related to my main tracking issue, but I didn't so I kinda lost track of it. My bad, but it's done now. :D

Issue History

Date Modified Username Field Change
2019-09-18 13:12 westor New Issue
2019-09-18 19:24 Gottem Assigned To => Gottem
2019-09-18 19:24 Gottem Status new => assigned
2019-09-18 19:54 Gottem Note Added: 0020902
2019-09-18 20:01 Gottem Severity major => minor
2019-09-20 21:18 westor Note Added: 0020903
2019-10-09 21:05 Gottem Note Added: 0020948
2019-10-09 21:05 Gottem Relationship added child of 0005282
2019-10-09 21:05 Gottem Status assigned => resolved
2019-10-09 21:05 Gottem Resolution open => fixed
2019-10-09 21:05 Gottem Fixed in Version => 5.0.0-alpha4