View Issue Details

IDProjectCategoryView StatusLast Update
0005460unrealinstallingpublic2019-11-29 10:00
ReporterschadenfredAssigned Tosyzop 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformx86-64OSAlpine linuxOS Version3.10.3
Product Version4.2.4.1 
Target VersionFixed in Version5.0.0-alpha3 
Summary0005460: make fails "s_bsd.c:533:8: error: too many arguments to function 'setpgrp'"
DescriptionNot sure if I set the severity correctly. It blocks the install, but it's a quick fix to get around it. Please reclassify as you see fit.

make fails because setpgrp is called in s_bsd.c with two arguments. Alpine's setpgrp only supports one argument.
To resolve, edit s_bsd.c and change line 533 to use setpgid instead of setpgrp
This allows a successful build, but I don't know what impact it will have on other platforms.

I'm new to C, so there may be another solution that I'm not aware of.
Steps To ReproduceLaunch a docker container using 3.10.3 Alpine linux. This is currently the latest version.
apk update
apk add curl libressl libressl-dev gcc musl-dev make openssh-client bitchx
adduser unrealircd -D
cd ~unrealircd
su unrealircd -c 'mkdir unrealinstall'
su unrealircd -c 'curl -s https://www.unrealircd.org/unrealircd4/unrealircd-4.2.4.1.tar.gz | tar xvz --strip-components=1 -C ~/unrealinstall '
cd unrealinstall
# Use the default values during the Config step
su unrealircd -c ./Config
su unrealircd -c make
Additional Informationuse default values during Config step.

From the alpine man pages for setpgrp:
Since glibc 2.19, the BSD-specific setpgrp() function is no longer exposed by <unistd.h>; calls should be replaced with the setpgid() call shown above.
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-10-31 21:23

administrator   ~0021066

Last edited: 2019-10-31 21:23

View 2 revisions

Worth mentioning that UnrealIRCd 5 (development version) does not have this issue, as that part of the code was cleaned up and changed to use setsid()

syzop

2019-11-29 10:00

administrator   ~0021137

I am closing this one. Reason is that U5 does not have this issue and stable U5 is less than a month away. For the U4 branch I prefer not to touch this code.

Thanks for the report, it's good to know that U5 does not have this particular issue. Feel free to test U5 to see if you can find any other issues, though ;)

Issue History

Date Modified Username Field Change
2019-10-28 17:09 schadenfred New Issue
2019-10-31 21:23 syzop Note Added: 0021066
2019-10-31 21:23 syzop Note Edited: 0021066 View Revisions
2019-11-29 10:00 syzop Assigned To => syzop
2019-11-29 10:00 syzop Status new => resolved
2019-11-29 10:00 syzop Resolution open => fixed
2019-11-29 10:00 syzop Fixed in Version => 5.0.0-alpha3
2019-11-29 10:00 syzop Note Added: 0021137