View Issue Details

IDProjectCategoryView StatusLast Update
0005462unrealircdpublic2019-11-18 15:04
ReporterThe_MythAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version18.04 LTS
Product Version5.0.0-beta1 
Target VersionFixed in Version5.0.0-rc2 
Summary0005462: Successful ident replies still leads to idents being prefixed with an ~
DescriptionWith the option set::options::identd-check enabled, users connecting to the network and successfully replying to identd checks still have their ident prefixed by an ~.

I've tested it with Quassel, TheLounge and IRCCloud.
Steps To Reproduce- Enable set::options::identd-check on your server and rehash
- Connect a user from a machine that replies to identd requests
- After successful reply and after complete connection the ident is still prefixed by an ~
Additional InformationConnection info notices using Quassel

[13:31:03] [testnet.ptirc.org] *** Checking ident...
[13:31:03] [testnet.ptirc.org] *** Received identd response
[13:31:05] Welcome to the PTirc IRC Network James!~QCloud@quassel.cloudbnc.tk

Same similar notices using the other clients specified
TagsNo tags attached.
3rd party modules

Activities

syzop

2019-11-02 09:54

administrator   ~0021067

Thanks for the report, I'll try to reproduce here on my end (sounds like that will be no problem) and fix the issue. The ident code was rewritten in U5 so it's possible that there are some issues in it... especially since it is not tested via the automated test framework.

syzop

2019-11-18 15:04

administrator   ~0021077

Fixed, thanks for the report! :)

commit 54513307eca7238f1978f7e901a14cc8b9e29994 (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Nov 18 15:02:55 2019 +0100

    Fix ident check not working with some (most?) clients. Reported by
    The_Myth in https://bugs.unrealircd.org/view.php?id=5462.
    Now the code is much more generic/liberal. And more ugly.

Issue History

Date Modified Username Field Change
2019-11-01 14:10 The_Myth New Issue
2019-11-02 09:54 syzop Note Added: 0021067
2019-11-02 09:54 syzop Assigned To => syzop
2019-11-02 09:54 syzop Status new => assigned
2019-11-02 09:54 syzop Product Version 5.0.0-alpha4 => 5.0.0-beta1
2019-11-18 15:04 syzop Status assigned => resolved
2019-11-18 15:04 syzop Resolution open => fixed
2019-11-18 15:04 syzop Fixed in Version => 5.0.0-rc2
2019-11-18 15:04 syzop Note Added: 0021077