View Issue Details

IDProjectCategoryView StatusLast Update
0005522unrealircdpublic2020-04-13 08:45
ReporterPeGaSuS Assigned Tosyzop  
PrioritynoneSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
PlatformUnixOSUbuntu 
Product Version5.0.1 
Summary0005522: add "*" to /ELINE command to cover all available bantypea
DescriptionAs the title explains, would be nice to have a "*" to create an /ELINE that would cover all available bantypes, instead the need to specify all bantypes when wanting to exempt an IP from all of them.
So, something like: /ELINE *@host * 0 reason

Cheers
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-01-05 09:28

administrator   ~0021203

The main problem is: what is "all" and do people really expect "all":
Sure, one can make * include really everything, but then it also bypasses throttle, qline restrictions and even maxperip restrictions. This is likely not always what the user expects.
So one hand users may expect to exempt only from *LINEs and Spamfilters, and on the other hand it is understandable that other users may expect really to include everything, including maxperip.
I avoided that issue by simply not offering the functionality. That way you have to choose the types to exempt explicitly.

In the configuration file "except ban" there is a type "all" and it is already a potential cause of trouble... it does not include qline bypassing but does include maxperip and such.. that is bad I think.

PeGaSuS

2020-02-17 22:45

reporter   ~0021345

IMHO, if we use "*" as to exempt a specific IP from all the possible protection measures, that's probably because we do have a strong reason.

I'll name a few that makes sense to me:
- Exempt network BNC services (same IP for all users)
- Exempt personal bots (entertainment bots, channel management bots, etc)
- Exempt a specific trusted ISP/BNC/Etc provider

Those are just some thoughts that came to my mind. Feel free to close this "issue" if you think that still the best option is to add specific types in the ELINE command

Cheers!

syzop

2020-04-13 08:45

administrator   ~0021459

Yeah I think it's better to be explicit rather than *. Thanks for the suggestion and feedback, though :)

Issue History

Date Modified Username Field Change
2020-01-05 08:00 PeGaSuS New Issue
2020-01-05 09:28 syzop Note Added: 0021203
2020-01-05 09:28 syzop Assigned To => syzop
2020-01-05 09:28 syzop Status new => feedback
2020-02-17 22:45 PeGaSuS Note Added: 0021345
2020-04-13 08:45 syzop Status feedback => closed
2020-04-13 08:45 syzop Resolution open => no change required
2020-04-13 08:45 syzop Note Added: 0021459