View Issue Details

IDProjectCategoryView StatusLast Update
0005528unrealircdpublic2020-01-12 13:20
ReporterwestorAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.1 
Target VersionFixed in Version5.0.2 
Summary0005528: /ELINE flags 'fg' doesn't working at all
DescriptionHello,

Official reported by Mi_01 he reported that flags 'fg' from /ELINE doesn't working, i tested and i saw that he was right.

Examples:

/spamfilter add -simple c gline 60 testing www.sex.com
/eline *@192.184.9.112 fg 0 testing
When someone says 'www.sex.com' then a gline placed that it shouldn't.
also if the gline is placed by spamfilter and the client threw out then he should be
able to connect again because 'g' flag was added on /ELINE but ircd doesn't allowing the client to connect.

- Thanks!
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-01-12 12:58

administrator   ~0021223

Hm, indeed, I can confirm the issue.

syzop

2020-01-12 13:04

administrator   ~0021224

Ah, this is annoying. There are multiple documentation mistakes in the /ELINE syntax printout:

gline should be G
spamfilter should be F
(and qline should be Q)

In addition to updating the documentation, it would probably be a good idea to warn or error or unknown character.

syzop

2020-01-12 13:20

administrator   ~0021225

Fixed now, thanks for the report!

Issue History

Date Modified Username Field Change
2020-01-11 23:16 westor New Issue
2020-01-12 12:58 syzop Assigned To => syzop
2020-01-12 12:58 syzop Status new => confirmed
2020-01-12 12:58 syzop Note Added: 0021223
2020-01-12 13:04 syzop Note Added: 0021224
2020-01-12 13:20 syzop Status confirmed => resolved
2020-01-12 13:20 syzop Resolution open => fixed
2020-01-12 13:20 syzop Fixed in Version => 5.0.2
2020-01-12 13:20 syzop Note Added: 0021225
2020-01-12 13:20 syzop Priority urgent => normal