View Issue Details

IDProjectCategoryView StatusLast Update
0005535unrealircdpublic2020-01-20 15:43
ReporterPeGaSuS Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntu 
Product Version5.0.1 
Fixed in Version5.0.2 
Summary0005535: Opers are only joined to the first channel if multiple channels are specified in set::oper-auto-join
DescriptionMy actual set::oper-auto-join block:
set { oper-auto-join "#opers,#services,#Control"; };

When I do: /OPER nick password, I'm only joined to the #opers channel (the first in the block).
Steps To Reproduce1) Make the set::oper-auto-join block as mine
2) Rehash the IRCd
3) Reconnect to the network
4) Do: /OPER nick password
5) You should be joined only to the first channel specified in the set::oper-auto-join block


If you're joined to all the channels specified in the set::oper-auto-join block:
6) Do: /MODE nick -o
7) Repeat step 4
8) Now you should be joined only to the first channel specified in the set::oper-auto-join block
Additional InformationTested ony testnet which doesn't have any third modules loaded
TagsNo tags attached.
3rd party modules

Activities

syzop

2020-01-20 15:43

administrator   ~0021235

Fixed, thanks for the report!

commit d30f7e006d2d8ddecb2c7bb1fa147042638be14e (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Jan 20 15:41:12 2020 +0100

    Specifying multiple channels ("#one,#two") in set::auto-join,
    set::oper-auto-join or tld::channel was broken. It worked for the
    very first user since boot or rehash, but after that only the
    first channel was joined. Reported by PeGaSuS in
    https://bugs.unrealircd.org/view.php?id=5535

Issue History

Date Modified Username Field Change
2020-01-18 16:04 PeGaSuS New Issue
2020-01-20 15:43 syzop Assigned To => syzop
2020-01-20 15:43 syzop Status new => resolved
2020-01-20 15:43 syzop Resolution open => fixed
2020-01-20 15:43 syzop Fixed in Version => 5.0.2
2020-01-20 15:43 syzop Note Added: 0021235