View Issue Details

IDProjectCategoryView StatusLast Update
0005541unrealircdpublic2020-01-26 10:02
ReporterLord255 Assigned Tosyzop  
PrioritylowSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.1 
Fixed in Version5.0.3 
Summary0005541: /stats Z does not work
Description/stats Z does not work, it only gives back the /stats "help"

see:
https://github.com/unrealircd/unrealircd/blob/b9729a4f294436d99ffb48f646c965f928a27f31/src/modules/stats.c#L100-L143


and:
https://github.com/unrealircd/unrealircd/blob/b9729a4f294436d99ffb48f646c965f928a27f31/src/modules/stats.c#L189-L233

Steps To Reproducejust simple try to use /stats Z
Additional Information
https://github.com/unrealircd/unrealircd/blob/b9729a4f294436d99ffb48f646c965f928a27f31/src/modules/stats.c#L100-L143
https://github.com/unrealircd/unrealircd/blob/b9729a4f294436d99ffb48f646c965f928a27f31/src/modules/stats.c#L189-L233


v5.0.2 also affected, but currently i have v5.0.1 :)
(therefor the product version set)
Tags/stats, unreal5
3rd party modules

Activities

PeGaSuS

2020-01-23 23:18

reporter   ~0021252

I can confirm the issue in my network (as oper). All other stats seems to work as intended though.

Cheers!

syzop

2020-01-26 10:02

administrator   ~0021261

Yeah memory stats were removed in https://github.com/unrealircd/unrealircd/commit/88f45020d8950306d918b5e89542cbdff1b6b2c0
They were outdated and incorrect since like... forever. And too much of a hassle to maintain it, which would need real dedication. So best just to remove it.

But I guess I forgot to remove 'Z' from the stats usage help (did remove R though).

syzop

2020-01-26 10:02

administrator   ~0021262

Fixed, thanks.

commit 1b07f706bc20e8d4784847696c982426745933de (HEAD -> unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sun Jan 26 10:00:58 2020 +0100

    Remove old STATS Z from stats help. Reported by Lord255 in
    https://bugs.unrealircd.org/view.php?id=5541

Issue History

Date Modified Username Field Change
2020-01-23 21:41 Lord255 New Issue
2020-01-23 21:41 Lord255 Tag Attached: /stats
2020-01-23 21:42 Lord255 Tag Attached: unreal5
2020-01-23 21:42 Lord255 Tag Detached: unreal5
2020-01-23 21:42 Lord255 Tag Attached: unreal5
2020-01-23 23:18 PeGaSuS Note Added: 0021252
2020-01-26 10:02 syzop Note Added: 0021261
2020-01-26 10:02 syzop Assigned To => syzop
2020-01-26 10:02 syzop Status new => resolved
2020-01-26 10:02 syzop Resolution open => fixed
2020-01-26 10:02 syzop Fixed in Version => 5.0.3
2020-01-26 10:02 syzop Note Added: 0021262