View Issue Details

IDProjectCategoryView StatusLast Update
0005644unrealircdpublic2020-04-25 16:45
ReporterBalthazar Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.4 
Fixed in Version5.0.5 
Summary0005644: Chanmode +kL redirects even if joining with correct channel key
DescriptionHi
When a user tries to join a channel with +Lk #chan key with the good key, the user is redirected to #chan anyway.


Steps To ReproduceSteps To Reproduce
Connect two nicknames
First nickname :
/join #randomchan
/mode #randomchan +kL bonjour #randomchan2

Second nickname :
/join #randomchan bonjour

You're redirected to #randomchan2 whereas the key is correct
Additional InformationThis bug is affecting both version 5.0.3.1 and 5.0.4
TagsNo tags attached.
3rd party modules

Activities

Lord255

2020-04-22 01:51

reporter   ~0021517

seems right.

"L - built-in - Channel link. If the +l user limit (see below) is reached then users will automatically be redirected to this channel. Example: +L #something"

msg:
#randomchan #randomchan2 [Link] Cannot join channel #randomchan (invalid channel key) -- transferring you to #randomchan2

syzop

2020-04-25 12:29

administrator   ~0021526

In link_pre_localjoin_cb the parv[] for the key is NULL, so the key is always invalid.
This is due to join.c:420:
parv[2] = NULL; /* for cmd_names call later, parv[parc] must == NULL */

Will fix later...

syzop

2020-04-25 16:45

administrator   ~0021527

Fixed now, thanks for the report!

https://github.com/unrealircd/unrealircd/commit/0902ed7a99643631c27fdbb3ead1d336633d1670

commit 0902ed7a99643631c27fdbb3ead1d336633d1670 (HEAD -> unreal50, origin/unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sat Apr 25 16:43:32 2020 +0200

    Fix channel mode +L redirecting even if joining with correct channel key.
    Reported by Balthazar in https://bugs.unrealircd.org/view.php?id=5644

Issue History

Date Modified Username Field Change
2020-04-21 13:23 Balthazar New Issue
2020-04-22 01:51 Lord255 Note Added: 0021517
2020-04-25 12:18 syzop Summary Chanmode +L with +k key takes precedence where as the good key is entered => Chanmode +kL redirects even if joining with correct channel key
2020-04-25 12:29 syzop Note Added: 0021526
2020-04-25 12:29 syzop Assigned To => syzop
2020-04-25 12:29 syzop Status new => confirmed
2020-04-25 16:45 syzop Status confirmed => closed
2020-04-25 16:45 syzop Resolution open => fixed
2020-04-25 16:45 syzop Fixed in Version => 5.0.5
2020-04-25 16:45 syzop Note Added: 0021527
2020-04-25 16:45 syzop Status closed => resolved