View Issue Details

IDProjectCategoryView StatusLast Update
0005680unrealircdpublic2020-05-25 15:11
Reportersyzop Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target Version5.0.5Fixed in Version5.0.5 
Summary0005680: +f being set multiple times on netsync
Description
14:37 -!- Netsplit irc1.unrealircd.org <-> irc2.unrealircd.org quits: @Erik, Az, Xibalba, rakiru, 
          KindOne_, AlbozZ, waveclaw, ossii, spectre, deathbybandaid,  (+25 more, use /NETSPLIT to show 
          all of them)
14:37 -!- mode/#unreal-support [+o Cronus] by ChanServ
14:37 -!- ServerMode/#unreal-support [+f [5j#R1,7m#M1,3n#N1,4t#b1]:6] by irc2.unrealircd.org
14:37 -!- ServerMode/#unreal-support [+f [5j#R1,7m#M1,3n#N1,4t#b1]:6] by irc2.unrealircd.org

It is odd that it shows +f being set 2 times in a row, in fact i would have expected 0 since the modes should have been that way already (users were in the channel)

Similarly, in #unreal-devel it showed up 1 time:
14:37 -!- Netsplit irc1.unrealircd.org <-> irc2.unrealircd.org quits: @Erik, Az, rakiru, jess, @i, 
          westor, w, yang, sam, Mirc0p,  (+1 more, use /NETSPLIT to show all of them)
14:37 -!- mode/#unreal-devel [+o Cronus] by ChanServ
14:37 -!- ServerMode/#unreal-devel [+f [5c#C5,15j#R5,60m#M5,10n#N5,20t#b1]:30] by irc2.unrealircd.org
14:37 -!- w [b@Clk-EE9782A0.gq] has joined #unreal-devel

TagsNo tags attached.
3rd party modules

Activities

syzop

2020-05-25 15:11

administrator   ~0021589

Could not reproduce locally but did find something.... probably this issue is fixed too by https://github.com/unrealircd/unrealircd/commit/640caf09a132ad6970eb7347920e10cfdb7688ec and https://github.com/unrealircd/unrealircd/commit/f56ac9384b08524cefa37b44d48b15357bee3437

Issue History

Date Modified Username Field Change
2020-05-25 14:39 syzop New Issue
2020-05-25 14:39 syzop Description Updated View Revisions
2020-05-25 14:40 syzop Description Updated View Revisions
2020-05-25 14:40 syzop Description Updated View Revisions
2020-05-25 15:10 syzop View Status private => public
2020-05-25 15:11 syzop Assigned To => syzop
2020-05-25 15:11 syzop Status new => resolved
2020-05-25 15:11 syzop Resolution open => fixed
2020-05-25 15:11 syzop Note Added: 0021589
2020-05-25 15:11 syzop Fixed in Version => 5.0.5