View Issue Details

IDProjectCategoryView StatusLast Update
0005823unrealircdpublic2021-11-01 10:35
ReporterPeGaSuS Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version20.04
Product Version5.0.8 
Fixed in Version6.0.0-beta1 
Summary0005823: Staff file doesn't work with remote url
DescriptionSo, I've tried the following:
loadmodule staff;
set { staff-file "https://user:password@sub.domain.tld/~unrealircd/.confs/network.staff"; }


And I got a:
*** Configuration loaded.
*** error: Error downloading https://***:***@vps1.ptirc.org/~unrealircd/.confs/network.staff: Invalid TIMEVALUE


Tried to use:
@define $STAFFCONTENT "https://user:password@sub.domain.tld/~unrealircd/.confs/network.staff";
loadmodule staff;
set { staff-file "$STAFFCONTENT";


I even tried to change the remote name to network.conf and no avail.

Remote file content:
### Admin(s) ####
James
### Co-Admin(s)  ###
TECO
### IRCop(s)  ###
All above
### Helper(s) ###
All above
TagsNo tags attached.
3rd party modules

Activities

PeGaSuS

2021-11-01 10:35

reporter   ~0022142

This seems to be fixed in the upcoming UnrealIRCd 6.

IMHO, can be closed.

Issue History

Date Modified Username Field Change
2021-03-06 21:50 PeGaSuS New Issue
2021-03-07 08:17 syzop Status new => acknowledged
2021-03-07 08:17 syzop Product Version => 5.0.8
2021-03-07 08:17 syzop Summary [5.0.9-git] Staff file doesn't work with remote url => Staff file doesn't work with remote url
2021-11-01 10:35 PeGaSuS Note Added: 0022142
2021-11-01 10:35 syzop Assigned To => syzop
2021-11-01 10:35 syzop Status acknowledged => resolved
2021-11-01 10:35 syzop Resolution open => fixed
2021-11-01 10:35 syzop Fixed in Version => 6.0.0-beta1