View Issue Details

IDProjectCategoryView StatusLast Update
0005836unrealircdpublic2021-03-21 07:40
ReporterLe_Coyote Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.0.9 
Fixed in Version5.0.10 
Summary0005836: security-group::tls cannot be used in config file.
DescriptionAlthough defaults groups such as tls-users make use of s->tls (see https://github.com/unrealircd/unrealircd/blob/unreal50/src/user.c#L829), there is no provision for security-group::tls in _conf_security_group, meaning the setting itself cannot be used in a configuration file, even though the logic itself (ie. matching tls users) is implemented.
TagsNo tags attached.
3rd party modules

Activities

Le_Coyote

2021-03-20 21:37

reporter   ~0021909

Pull request made with proposed patch, works in my test environment. Hope I didn't leave anything out but it appears to do the job.

syzop

2021-03-21 07:40

administrator   ~0021910

Yup, patch looks fine, applied. Thanks! :)

commit 00711f905c6a2f7ca5c0b57098c742a2eaa3451b (HEAD -> unreal50, origin/unreal50)
Author: LeCoyote <lecoyote@lecoyote.org>
Date: Sun Mar 21 07:39:49 2021 +0100

    Actually read security-group::tls from the conf file (fixes 0005836) (#133)

Issue History

Date Modified Username Field Change
2021-03-20 21:18 Le_Coyote New Issue
2021-03-20 21:37 Le_Coyote Note Added: 0021909
2021-03-21 07:40 syzop Assigned To => syzop
2021-03-21 07:40 syzop Status new => resolved
2021-03-21 07:40 syzop Resolution open => fixed
2021-03-21 07:40 syzop Fixed in Version => 5.0.10
2021-03-21 07:40 syzop Note Added: 0021910