View Issue Details

IDProjectCategoryView StatusLast Update
0005913unrealircdpublic2021-06-15 20:05
Reporterarmyn Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version5.2.0 
Fixed in Version5.2.0.1 
Summary0005913: Problem spamfilter - It sometimes ignores
DescriptionSteps to reproduce:
Steps To Reproduce1) Run /spamfilter add -regex c gline 8h ind├ęsirable prelimin
2) Type prelim, no gline

With other commands like "block" and "shun", sometimes it can kick the user but sometimes it ignores, difficult to explain
TagsNo tags attached.
3rd party modules

Activities

PeGaSuS

2021-06-15 19:59

reporter   ~0022005

Can confirm the issue.
Tried with "antispamfilter", "^.*antispamfilter.*$" and even "/antispamfilter/" for regex and "*antispamfilter*" for simple.

One example:
[19:40:32] [irc1.ptirc.org] *** Spamfilter added: 'antispamfilter' [type: regex] [target: c] [action: block] [reason: Spam/Flood/Advertising/Other abuses] on Tue Jun 15 17:42:32 2021 GMT (from James!James@PTirc/Users/James)

[19:42:15] --> PTirc-4015 (~Wockets@DAB1F162.F8B482F.58EF52D7.IP) has joined #spamtest
[19:43:34] <PTirc-4015> this is an antispamfilter test

[19:46:09] [irc1.ptirc.org] *** James!James@PTirc/Users/James removed Spamfilter '^.*prelim.*$' (set at Tue Jun 15 17:40:32 2021) ## why the time is UTC instead the machine time that is CEST (+0200) i don't know ##

syzop

2021-06-15 20:05

administrator   ~0022006

Thanks, fixed now https://github.com/unrealircd/unrealircd/commit/8a655b8bb4a048ce07a30c1207214293edcc529c

commit 8a655b8bb4a048ce07a30c1207214293edcc529c (HEAD -> unreal52, origin/unreal52, origin/HEAD)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Tue Jun 15 20:01:58 2021 +0200

    Fix spamfilter not working with type 'c'.
    If you had a spamfilter on type 'c' but not on 'p' then it would not
    trigger. Reported by armyn in https://bugs.unrealircd.org/view.php?id=5913
    This probably went unnoticed because most people add spamfilters
    on 'pc' (or even 'pcnN').

Issue History

Date Modified Username Field Change
2021-06-15 19:15 armyn New Issue
2021-06-15 19:59 PeGaSuS Note Added: 0022005
2021-06-15 20:00 syzop Assigned To => syzop
2021-06-15 20:00 syzop Status new => confirmed
2021-06-15 20:05 syzop Status confirmed => resolved
2021-06-15 20:05 syzop Resolution open => fixed
2021-06-15 20:05 syzop Fixed in Version => 5.2.0.1
2021-06-15 20:05 syzop Note Added: 0022006