View Issue Details

IDProjectCategoryView StatusLast Update
0005996unrealircdpublic2021-11-20 07:55
Reportersyzop Assigned Tosyzop  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.0-beta2 
Target Version6.0.0-beta3Fixed in Version6.0.0-beta3 
Summary0005996: Windows version does not like @endif
DescriptionWeird issue, it complains about @endif being an unknown preprocessor directive.
In beta1 and beta2 i therefore temporarily removed the @if and @endif from modules.default.conf but this is stupid.
TagsNo tags attached.
3rd party modules

Activities

syzop

2021-11-07 15:43

administrator   ~0022175

commit ca2d15360be320a46c091d610e5bd7a87551c5f2 (HEAD -> unreal60_dev, origin/unreal60_dev)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sun Nov 7 15:06:17 2021 +0100

    Make @endif work on Windows.
    
    This is due to \r being replaced with a space in config_parse_with_offset().
    Didn't even know that.. yeah.. ugly ugly... but first time i see it
    causing a problem in 20 years.

Issue History

Date Modified Username Field Change
2021-11-07 09:21 syzop New Issue
2021-11-07 15:43 syzop Assigned To => syzop
2021-11-07 15:43 syzop Status new => resolved
2021-11-07 15:43 syzop Resolution open => fixed
2021-11-07 15:43 syzop Fixed in Version => 6.0.0-beta3
2021-11-07 15:43 syzop Note Added: 0022175
2021-11-20 07:55 syzop View Status private => public