View Issue Details

IDProjectCategoryView StatusLast Update
0006003unrealircdpublic2022-03-23 13:02
Reporterfo Assigned Tosyzop  
PrioritynoneSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Fixed in Version6.0.3 
Summary0006003: Extend /stats O with info about operclass
DescriptionAt this moment, /stats O returns information in the following format:
server.tld: O *@* * operA - class1
server.tld: O *@* * operB - class2
server.tld: O *@* * operC - class3

where class[1..3] is connection class specified in oper block for a specific oper. I suggest extending this output with info about oper's oper class.

Patch which achieves described behaviour is attached (N.B.: it was tested very lightly)
TagsNo tags attached.
3rd party modules

Activities

fo

2021-11-20 12:37

reporter  

syzop

2021-11-20 18:19

administrator   ~0022198

Haven't looked at the patch but I agree.

syzop

2022-03-23 13:02

administrator   ~0022422

Thanks for the suggestion and the patch. Added in UnrealIRCd 6.0.3 with modifications. Very similar to the patch but sending operclass,class instead of class,operclass and not changing the numeric definition. This makes it sortof conform to https://defs.ircdocs.horse/defs/numerics.html#rpl-statsoline-243 (not terribly important, but it was perfectly possible in this case)

For history, this is how it evolved:
UnrealIRCd 3.2.x: we sent the oper flags (eg oOabcdetc)
UnrealIRCd 4.x / 5.x: we sent "-" (so a hyphen) since we moved to operclasses
UnrealIRCd 6.0.3+: we now send the operclass instead of the "-"

https://github.com/unrealircd/unrealircd/commit/28c1b9cef9bd2637e2194855b0010f352ab0f64e

Issue History

Date Modified Username Field Change
2021-11-20 12:37 fo New Issue
2021-11-20 12:37 fo File Added: 0001-Add-operclass-info-in-stats-O.patch
2021-11-20 18:19 syzop Assigned To => syzop
2021-11-20 18:19 syzop Status new => has patch
2021-11-20 18:19 syzop Note Added: 0022198
2022-03-23 13:02 syzop Status has patch => resolved
2022-03-23 13:02 syzop Resolution open => fixed
2022-03-23 13:02 syzop Fixed in Version => 6.0.3
2022-03-23 13:02 syzop Note Added: 0022422