View Issue Details

IDProjectCategoryView StatusLast Update
0006015unrealircdpublic2021-11-29 18:21
Reporterprogval Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version6.0.0-rc2 
Summary0006015: KICK doesn't support multiple channels anymore, despite unchanged TARGMAX
DescriptionHi,

Unreal 6 doesn't seem to support multi-channel KICKs anymore, despite KICK:4 in its TARGMAX ISUPPORT token.

Relevant spec: https://modern.ircdocs.horse/#kick-message
Steps To Reproduce1 -> S: KICK #chan,#chan bar,baz :bye
S -> 1: :My.Little.Server 403 foo #chan,#chan :No such channel
TagsNo tags attached.
3rd party modules

Activities

syzop

2021-11-29 17:22

administrator   ~0022214

Last edited: 2021-11-29 17:23

TARGMAX applies to users, so it's not that.

You know multi-channel kick is controversial right? Because something like "KICK #chan1,#chan2 a,b,c" is ambiguous. Lots of IRCds, including UnrealIRCd, hybrid, seven, and so on (or at least until recently), only support it for a single channel.. where we do support multi-user kick ("KICK #chan1 a,b,c").

But, you are right that we used to cut on the first comma in UnrealIRCd 3.2/4.x/5.x. So I will do that change.

syzop

2021-11-29 18:21

administrator   ~0022218

Done, thanks for the report :)

commit d59537391a067d926db6c395e966480ade246033 (HEAD -> unreal60_dev, origin/unreal60_dev)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Nov 29 17:23:45 2021 +0100

    Cut off channel for KICK at first comma, as we did in U3.2/U4/U5.
    Reported by progval in https://bugs.unrealircd.org/view.php?id=6015

Issue History

Date Modified Username Field Change
2021-11-28 20:35 progval New Issue
2021-11-29 17:22 syzop Note Added: 0022214
2021-11-29 17:23 syzop Note Edited: 0022214
2021-11-29 18:21 syzop Assigned To => syzop
2021-11-29 18:21 syzop Status new => resolved
2021-11-29 18:21 syzop Resolution open => fixed
2021-11-29 18:21 syzop Fixed in Version => 6.0.0-rc2
2021-11-29 18:21 syzop Note Added: 0022218