View Issue Details

IDProjectCategoryView StatusLast Update
0006038unrealircdpublic2021-12-26 14:56
Reporterarmyn Assigned Tosyzop  
PrioritynormalSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version6.0.0 
Fixed in Version6.0.1 
Summary0006038: The "set time" in the snotice glines has been removed
DescriptionG-Line added: '*@2a02:a03f:xxxxxx:100:4fd:e979:690f:d478' [reason: the reason.] [by: martin!mar@host] [expires: Sat Dec 25 15:26:53 2021 GMT]

Has the "set time" been removed for good or has it been forgotten to be put back?
In fact with the set time and the expire time I could still calculate the time difference from which the person was banned, but there it is no longer possible. And very often I do not know it is not possible to base oneself only on the expire time because of GMT + etc ... but before on unrealircd it was possible to make the difference between the set time and the expire time without relying on the actual date from my computer

Old gline snotice on unrealircd 5 with set time and expire time:
*** G-Line added for *@197.19.xxx.135 on Tue Dec 14 23:00:40 2021 GMT (from Sysop!SysOp@xxx.com to expire at Wed Dec 15 00:00:40 2021 GMT: Ce pseudo est incorrect !
TagsNo tags attached.
3rd party modules

Activities

syzop

2021-12-26 07:38

administrator   ~0022297

Yes, I removed them because they are unnecessary information. It always annoyed me in the past, but now I was going through all snomask and log messages, in UnrealIRCd 6, so I changed it.

May I ask where you use the information for / what you do with it?
And maybe I misunderstood but... Do I understand correctly that you actually don't need the "set at" but are more interested in the "duration"? (eg "1 day")
Is it for a bot? Or script? Or?

armyn

2021-12-26 08:09

reporter   ~0022298

It's for reading (through my eyes) to read the "set time" and "expire time" both at the same time.
This is to calculate the time difference, to find out if my colleagues do not ban users for too long longer than normal for almost no reason.


It is not possible to use the time of the mIRC / AdiIRC script to make this difference, because of gmt + 0 + 1 + 2 + 3 ... and "expire time".
Before I never read my client's mirc time but always the "set time" and "expire time"

armyn

2021-12-26 08:12

reporter   ~0022299

or then put the "expire time" to the time of the dedicated server, it is not possible? I could then look at the time of my script

syzop

2021-12-26 08:28

administrator   ~0022300

I am sure a mIRC script can solve it, but I am trying to "take a step back" to look at the original problem / original situation, which is always a good idea :)
" to find out if my colleagues do not ban users for too long longer than normal for almost no reason."
Right.. understood.
Maybe something like this added to the message: [duration: 1h] ?

I am thinking maybe we should remove "[expires: xyz]" and have "[duration: 1d3h5m]" instead. Most people reading the message are interested in that relative time, and almost never in the exact time it expires.

syzop

2021-12-26 09:05

administrator   ~0022301

Last edited: 2021-12-26 09:05

I've now done this https://github.com/unrealircd/unrealircd/commit/f7719d2de2a4cdfb08486e9ee1468559b641f467

Shows like this:
:maintest.test.net NOTICE s5667 :tkl.TKL_ADD 03[info] G-Line added: '*@1.2.3.4' [reason: this is a one minute gline] [by: s5667!~x@oper/netadmin.test.net] [duration: 1m]
:maintest.test.net NOTICE s5667 :tkl.TKL_ADD 03[info] Z-Line added: '*@5.5.5.5' [reason: This is a ten seconds zline] [by: s5667!~x@oper/netadmin.test.net] [duration: 10s]
:maintest.test.net NOTICE s5667 :tkl.TKL_EXPIRE 03[info] Expiring Z-Line '*@5.5.5.5' [reason: This is a ten seconds zline] [by: s5667!~x@oper/netadmin.test.net] [duration: 10s]
:maintest.test.net NOTICE s5667 :tkl.TKL_EXPIRE 03[info] Expiring G-Line '*@1.2.3.4' [reason: this is a one minute gline] [by: s5667!~x@oper/netadmin.test.net] [duration: 1m]

I like it. Clean, short and readable.

Good for you too?

armyn

2021-12-26 09:58

reporter   ~0022302

Ah yes that's great, the "duration" tag is even better as an idea.
By also leaving the "expires" is not also good in front of the "duration" ?!

from :
:maintest.test.net NOTICE s5667 :tkl.TKL_ADD 03[info] G-Line added: '*@1.2.3.4' [reason: example] [by: s5667!~x@oper/netadmin.test.net] [duration: 4d]
to :
:maintest.test.net NOTICE s5667 :tkl.TKL_ADD 03[info] G-Line added: '*@1.2.3.4' [reason: example] [by: s5667!~x@oper/netadmin.test.net] [expires: Sun Dec 30 08:51:55 2021 GMT] [duration: 4d]

because that way we know that in 4 days, it will be December 30, this allows us to avoid thinking

Both tags at the same time is useful

Or I have to get used to it for 1 month, to see if we should not do too much mental arithmetic while reading the snotice with "duration" only

syzop

2021-12-26 14:56

administrator   ~0022303

I will go with only 'duration'. I think in practice it will be OK.

Issue History

Date Modified Username Field Change
2021-12-25 16:21 armyn New Issue
2021-12-26 07:38 syzop Note Added: 0022297
2021-12-26 07:38 syzop Assigned To => syzop
2021-12-26 07:38 syzop Status new => feedback
2021-12-26 08:09 armyn Note Added: 0022298
2021-12-26 08:12 armyn Note Added: 0022299
2021-12-26 08:28 syzop Note Added: 0022300
2021-12-26 09:05 syzop Note Added: 0022301
2021-12-26 09:05 syzop Note Edited: 0022301
2021-12-26 09:58 armyn Note Added: 0022302
2021-12-26 14:56 syzop Status feedback => resolved
2021-12-26 14:56 syzop Resolution open => fixed
2021-12-26 14:56 syzop Fixed in Version => 6.0.1
2021-12-26 14:56 syzop Note Added: 0022303