View Issue Details

IDProjectCategoryView StatusLast Update
0006056unrealinstallingpublic2022-05-23 09:08
Reporterghenry Assigned To 
PrioritylowSeverityblockReproducibilityalways
Status newResolutionopen 
Product Version6.0.1 
Summary0006056: Supporting older gcc versions
DescriptionHi all,

I should be on a newer OS for this install, but hey. I had to switch

#if defined(__GNUC__)

to

#if defined(__GNUC__) && __GNUC__ >= 5

in

src/send.c
src/modules/tkl.c

on CentOS 6.10

all built now and running fine.

Thanks.
TagsNo tags attached.
3rd party modules

Activities

syzop

2022-05-23 09:08

administrator   ~0022507

k4be also hit this but... yeah... need to carefully "fix" this everywhere then, without causing breakage at other places (eg the suggestion in this report hard-assumes a warning is not generated below 5.x and thus only suppresses it >=5.x but perhaps there is a 4.something that does generate the warning and needs the suppression.

Unfortunately it seems most people that got hit by this problem have no interest in really fixing it either.

Which is kinda understandable... -grin-....

It also begs the question if we really want to support 13 year old compilers. Otherwise just close this if nobody provides provides a "perfect patch" ? I will keep it open for a few more months, but then... :)

Issue History

Date Modified Username Field Change
2022-01-13 11:22 ghenry New Issue
2022-05-23 09:08 syzop Note Added: 0022507