View Issue Details

IDProjectCategoryView StatusLast Update
0006121unrealircdpublic2022-06-01 08:52
Reporterwestor Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.4-rc1 
Fixed in Version6.0.4-rc2 
Summary0006121: Connthrottle module report invalid statistics
DescriptionHello,

I was testing the connthrottle module and after attack ends, module reports the statistics but here seems are incorrect.

connthrottle.CONNTHROTLE_REPORT [info] ConnThrottle] Stats for this server past 60 secs: Connections rejected: 16. Accepted: $num_accepted_known_users known user(s), $num_accepted_sasl SASL, $num_accepted_webirc WEBIRC and 20 new user(s).

The issue is under https://github.com/unrealircd/unrealircd/blob/unreal60_dev/src/modules/connthrottle.c#L370-L375 but i don't wanna touch that :P

- Thanks!
TagsNo tags attached.
3rd party modules

Activities

syzop

2022-06-01 08:52

administrator   ~0022545

Indeed you are right, thanks for the bug report :)

Had to think a little on how i wanted to do this, now that we no longer have distinct statistics for each category like SASL/identified/etc, which is a side effect of the new except { } block that cannot be solved.

Done now, it is like this:
Stats for this server past 60 secs: Connections rejected: 1. Accepted: 0 except user(s) and 1 new user(s).

https://github.com/unrealircd/unrealircd/commit/1311c8a963b3a5d6e5cf14d0e3ac42146d3728a4
commit 1311c8a963b3a5d6e5cf14d0e3ac42146d3728a4 (HEAD -> unreal60_dev, origin/unreal60_dev, origin/HEAD)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Jun 1 08:49:35 2022 +0200

    Fix connthrottle message when throttling (bug introduced in 6.0.4-rc1).
    Reported by westor in https://bugs.unrealircd.org/view.php?id=6121

Issue History

Date Modified Username Field Change
2022-06-01 03:09 westor New Issue
2022-06-01 08:52 syzop Assigned To => syzop
2022-06-01 08:52 syzop Status new => resolved
2022-06-01 08:52 syzop Resolution open => fixed
2022-06-01 08:52 syzop Fixed in Version => 6.0.4-rc2
2022-06-01 08:52 syzop Note Added: 0022545