View Issue Details

IDProjectCategoryView StatusLast Update
0006352unrealinstallingpublic2023-11-29 09:13
Reporterk4be Assigned Tosyzop  
Status resolvedResolutionfixed 
Product Version6.1.2.3 
Fixed in Version6.1.3-rc1 
Summary0006352: Certain set of modules failing compilation halts the whole build
DescriptionThe problem was noticed when trying to build v provided with 5.x modules. The build process does not download new versions of modules from the repo (which are available; one of them fails to build though) and exits with an error. It's impossible to proceed to `make install` without moving the module sources out of `third/` directory.
Steps To ReproducePlace provided modules in `src/modules/third`of a fresh source tree. Run `./Config` and `make install`.
It is possible that the problem is triggered by `third/listrestrict` from the repo failing to compile. If (when) it gets fixed, it may be needed to replace modules.sources.list with some other prepared data (not tested by me).
Attached Files
fail-modules.tar.gz (30,587 bytes)
3rd party modulesa set is attached



2023-11-26 18:56

administrator   ~0023107

Oh... of course now that i test it more than a month later everything compiles :D


2023-11-26 19:01

administrator   ~0023108

As I couldn't reproduce anymore, I tested it by downloading another module...
I did "echo >src/modules/third/rtkl.c" to create a dummy file, then ran 'make install'

What happens is that UnreallIRCd tried to fetch a new version of the module, that module fails to compile, but it does compile the rest, and "make install" continues and installs everything.

Do you have terminal output? Was this non-Linux?

Also, it might be accidentally fixed by my other modulemanage/makefile changes... though i don't immediately see how, but i did change stuff.


2023-11-26 19:33

developer   ~0023109

I've tried current git with modules.list file which contains a failing module:
Now `make` is not exiting on its build failure, but no further module is updated even if it exists in the repo.


2023-11-26 20:14

administrator   ~0023111

Ah ok, yeah i tried with rtkl, but maybe it depends on "ordering" like if a module comes AFTER that one. Will maybe have a look tomorrow again :)


2023-11-29 08:50

administrator   ~0023112

Last edited: 2023-11-29 08:51

Yeah I can reproduce now, it depends on arbitrary order so had some problems reproducing it earlier. Reproducer:
cd ~/Unreal6
echo >src/modules/third/clearlist.c
echo >src/modules/third/rtkl.c
echo >src/modules/third/restrict-chans.c
make install

Then after rtkl failure, it skips restrict-chans.


2023-11-29 09:12

administrator   ~0023113

Last edited: 2023-11-29 09:13

Fixed now. Note that we report the error but still continue the compile (which is intended), but it fixes your issue where 1 failed module compile prevents the rest from upgrading.

Commit 9685d1e0525943bc53676d911ffc3b2c3b3ee79c (HEAD -> unreal60_dev, origin/unreal60_dev, origin/HEAD)
Author: Bram Matthys <[email protected]>
Date: Wed Nov 29 09:08:55 2023 +0100

    Fix module manager: if 1 upgrade failed, the remaining were not upgraded.
    Reported by k4be in

Issue History

Date Modified Username Field Change
2023-10-16 17:21 k4be New Issue
2023-10-16 17:21 k4be Tag Attached: make
2023-10-16 17:21 k4be File Added: fail-modules.tar.gz
2023-11-26 18:56 syzop Note Added: 0023107
2023-11-26 19:01 syzop Note Added: 0023108
2023-11-26 19:01 syzop Assigned To => syzop
2023-11-26 19:01 syzop Status new => feedback
2023-11-26 19:33 k4be Note Added: 0023109
2023-11-26 20:14 syzop Note Added: 0023111
2023-11-29 08:50 syzop Note Added: 0023112
2023-11-29 08:50 syzop Status feedback => confirmed
2023-11-29 08:50 syzop Note Edited: 0023112
2023-11-29 08:51 syzop Note Edited: 0023112
2023-11-29 09:12 syzop Status confirmed => resolved
2023-11-29 09:12 syzop Resolution open => fixed
2023-11-29 09:12 syzop Fixed in Version => 6.1.3-rc1
2023-11-29 09:12 syzop Note Added: 0023113
2023-11-29 09:13 syzop Note Edited: 0023113