View Issue Details

IDProjectCategoryView StatusLast Update
0001034unrealircdpublic2004-05-26 21:40
ReporterLRL Assigned Tocodemastr 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version3.2-beta16 
Summary0001034: Problems with the ircd.log
DescriptionI've noticed 2 problems, maybe it's just me. Every 5 minutes when the crontab checks the ircd it writes a log entry about binding to a port...
[Sat Jun 14 18:40:00 2003] - Error binding stream socket to IP 216.200.173.219 port 7000 - irc.winbolo.us[]:Address already in use
[Sat Jun 14 18:45:00 2003] - Error binding stream socket to IP 216.200.173.219 port 7000 - irc.winbolo.us[]:Address already in use
[Sat Jun 14 18:50:00 2003] - Error binding stream socket to IP 216.200.173.219 port 7000 - irc.winbolo.us[]:Address already in use
Port 7000 is the server's ssl port, altho you can connect on the port, this rather floods the log file. Also if you have the option to log oper attempts, it only logs successful attemps.
Attached Files
ircd.log (5,496 bytes)
3rd party modules

Activities

codemastr

2003-06-15 16:52

reporter   ~0002969

Fixed in .1836

LRL

2003-06-20 05:59

reporter   ~0003003

These issues are still occuring in beta 17, same thing with the bind stuff and it not logging failed oper attemps

LRL

2003-06-20 06:09

reporter   ~0003004

I get noticed..
[23:33] -irc.winbolo.us- *** Notice -- Client connecting on port 6667: Nemokrad ([email protected]) [clients]
-
[23:33] -irc.winbolo.us- *** Notice -- Failed OPER attempt by Nemokrad ([email protected]) [unknown oper]
-
[23:33] -irc.winbolo.us- *** Notice -- Client connecting on port 6667: Killjoy ([email protected]) [clients]
-
[23:33] -irc.winbolo.us- *** Notice -- Client exiting: Nemokrad ([email protected]) [Client exited]

And in the log It shows...
[Thu Jun 19 22:30:00 2003] - Error binding stream socket to IP 216.200.173.219 port 7000 - irc.winbolo.us[]:Address already in use
[Thu Jun 19 22:33:48 2003] - Connect - [email protected]
[Thu Jun 19 22:33:49 2003] - Connect - [email protected]
[Thu Jun 19 22:33:53 2003] - Disconnect - (0:0:6) [email protected]
[Thu Jun 19 22:33:59 2003] - Disconnect - (0:0:11) [email protected]

AngryWolf

2003-06-21 14:00

reporter   ~0003006

I also think it would be a great feature to log bad oper attempts just like the way I get notices about them, because I can't be always online to see if someone tries to oper-up him/herself by guessing the password, etc. However, what's then if people acts like flooding with /oper's? Because then the whole logfile can reach a configured file size limit, so I can lose more useful information than I expect, and I have to kill those users to stop that...

LRL

2003-06-22 10:22

reporter   ~0003022

I went through some of the logging, and what the documents say it should do. It dosen't.
errors (yes works, but some of the errors logged needs fixing)
kills (Yes, works fine)
tkl (yes, Works fine)
connects logs user connects/quits (yes, Works fine)
server-connects logs server connects/squits (dosen't log anything for server connects or squits)
kline logs kline and unkline (logs adding a kline, dosen't log unkline)
oper logs oper attempts (both failed and successful) (Nothing here works)

I don't know about most people but I tend to review my logs, and use them for alot of things. I hope this helps you guys to fix these problems.

LRL

2003-07-02 14:58

reporter   ~0003151

Could I get some sort of offical acknowledgment?

codemastr

2003-07-15 18:22

reporter   ~0003238

Errors:
What do you mean some logging needs to be fixed?

Server-Connects:
You are right about this as well, this is now fixed in .1856:
[Tue Jul 15 14:06:05 2003] - SQUIT test.testnet.org (Testing)
[Tue Jul 15 14:20:59 2003] - SERVER test.testnet.org

Kline:
This is really obsolete and will probably be removed. Klines are now handled by the tkl system so the tkl flag handles this. I have no idea how you are saying this does log klines being added because well.. the flag is never actually used anywhere in the code. However you are right that kline removal(actually effects kline/zline/gline/shun) didn't log, this is fixed in .1856:
[Tue Jul 15 13:58:21 2003] - [email protected] removed Timed K:Line *@test.com (set at Tue Jul 15 17:58:10 2003 - reason: no reason)


Oper:
Successful oper logging works fine for me in b17:
[Tue Jul 15 13:48:42 2003] - OPER (codemastr) by (codemastr!n64master@localhost)
However you were right about failed logging, this is corrected in .1856:
[Tue Jul 15 13:52:06 2003] - OPER FAILEDAUTH (codemastr) by (codemastr!n64master@localhost)
[Tue Jul 15 13:53:06 2003] - OPER NOHOSTMATCH (codemastr) by (codemastr!n64master@localhost)

Can you upgrade to the current cvs and verify that it is working so that I may close this bug?

LRL

2003-07-16 09:47

reporter   ~0003250

Last edited: 2003-07-16 09:50

Everything except for the errors logging option is fine now, I don't know, but I would guess that this error '[Wed Jul 16 02:35:00 2003] - Error binding stream socket to IP 216.200.173.219 port 7000 - irc.winbolo.us[]:Address already in use' is a problem with the logging or maybe something to do with the ircdchk. If it's a ircdchk problem I'd guess it has something to do with 'kill -CHLD' Port 7000 is the ssl port, and it logs an error every 5 minutes (When crontab runs) Although I only get this error on ssl ports, yet there seems to be no problems with using the port.

edited on: 07-16-03 09:50

codemastr

2003-07-16 14:26

reporter   ~0003251

I'll try and look more closely at ircdchk, thats where I believe the problem is.

codemastr

2003-07-16 21:32

reporter   ~0003254

I think I found the cause, cvs update then run
./Config -q

I think the problem was due to incorrect paths in the ircdchk file, so now instead of using relative paths, it uses absolute paths which are now filled in automatically when you ./Config.

LRL

2003-07-18 03:05

reporter   ~0003262

Last edited: 2003-07-18 09:25

nope, still a bind error as befor. Although I did find something interesting, when I first booted this time I used the ircdchk, it booted fine, then executed the ircdchk again to test, no bind error. After I setup crontab (every 5 minutes), the first time it checked it there was no error. On the second time, there was an error. The when I went to execute the ircdchk it would show an error each time I manual did it aswell. This happens on freeBSD 4.8-stable, mandrake and on debian, that I know of for sure.

what about using ps to find the process instead of kill?

edited on: 07-18-03 09:25

codemastr

2003-07-18 15:13

reporter   ~0003275

You can't accurately use ps to find out if a process is running. Since you're saying you can manually cause this using ircdchk got a couple of questions. Does the ircd.pid file (the one referenced in ircdchk) exist? If so, what does it contain? Does that pid show up in ps ux? If you type kill -chld that_pid, what happens? The problem is, it works fine for me, I have the crontab set to run every 5 mins, and it has been running for over 2 days now without generating a single error.

LRL

2003-07-18 21:47

reporter   ~0003282

The ircd.pid file contains "1548" and that is the pid of the ircd process in ps ux. On kill -chld 1548 it just brings me back to a prompt. still showing the bind errors, when I cd into ircdcron and type ircdchk I get 'bash: ircdchk: command not found' yet each time I do this it creates an error in the log.
[Fri Jul 18 13:20:01 2003] - Connect - [email protected]
[Fri Jul 18 13:40:00 2003] - Error binding stream socket to IP 0.0.0.0 port 7000 - irc.winbolo.us[]:Address already in use
[Fri Jul 18 13:40:09 2003] - Error binding stream socket to IP 0.0.0.0 port 7000 - irc.winbolo.us[]:Address already in use
[Fri Jul 18 13:40:21 2003] - OPER (lrl) by ([email protected])
[Fri Jul 18 13:43:37 2003] - Error binding stream socket to IP 0.0.0.0 port 7000 - irc.winbolo.us[]:Address already in use
[Fri Jul 18 13:44:38 2003] - Error binding stream socket to IP 0.0.0.0 port 7000 - irc.winbolo.us[]:Address already in use
[Fri Jul 18 13:45:00 2003] - Error binding stream socket to IP 0.0.0.0 port 7000 - irc.winbolo.us[]:Address already in use
 The errors between 13:40 and 13:45 are manual. One thing weird here, is between 13:20 when the ircd was started and 13:40 it didn't show any errors, it was started at 13:20 by cron. I thought I had port 7000 set with the option of ssl, but appearently with the config I'm using I didn't. dossen't seem to matter, I get an error rather it's set ssl or not. I only show the error on port 7000, not with any other port regardless of the options set in the listen block.

codemastr

2003-07-18 22:06

reporter   ~0003283

When you did kill -chld it added another error to the log?

LRL

2003-07-18 22:13

reporter   ~0003284

nope

codemastr

2003-07-18 22:16

reporter   ~0003285

When you run ./ircdchk from ircdcron, can you paste the output it gives you?

LRL

2003-07-29 09:25

reporter   ~0003365

[16:18] <codemastr> can you cd to ircdcron and type ./ircdchk and tell me what it says?
[16:18] <LRLd> k
[16:22] <LRLn> Couldn't find the ircd running. Reloading it..
[16:22] <codemastr> hmm
[16:22] <codemastr> ok
[16:22] <LRLn> etc
[16:22] <codemastr> but it doesn't say "stale ircd.pid" ?
[16:23] <LRLn> nope
[16:23] * Sinus ([email protected]) has joined #unreal-support
[16:23] <codemastr> hmm well then that only leaves one option
[16:24] <codemastr> in ircdchk see the line that starts with ircdname=" ?
[16:24] <codemastr> type ls -l that.file.name and paste the results
[16:26] <LRLn> ls: ircd.pid: No such file or directory
[16:26] <codemastr> I thought you said ircd.pid exists?
[16:26] <LRLn> it did
[16:26] <codemastr> and it doesn't anymore?
[16:26] <LRLn> noper
[16:26] <codemastr> hmm
[16:27] <codemastr> restart Unreal so that it gets created
[16:27] <codemastr> what I'm thinking is, the problem is permissions
[16:27] <codemastr> crond doesn't have access to read the ircd.pid
[16:28] <LRLn> ah
[16:28] <LRLn> k, restarted
[16:28] <codemastr> in which case I'll try and come up with a workaround
[16:29] <LRLn> but why is the error only with one port?
[16:29] <codemastr> not totally sure

LRL

2003-07-29 09:27

reporter   ~0003366

I uploaded the log file where the IRCd has been running all this time, it switched and started whinning about the other ssl port, then just stoped the errors. :/

syzop

2003-09-05 21:19

administrator   ~0003593

hmm what's the current status of this?
you say "then just stoped the errors", does that mean it's fixed?

syzop

2004-05-26 21:40

administrator   ~0006441

Just assuming fixed to be...

Issue History

Date Modified Username Field Change
2003-06-15 04:46 LRL New Issue
2003-06-15 16:52 codemastr Status new => resolved
2003-06-15 16:52 codemastr Resolution open => fixed
2003-06-15 16:52 codemastr Assigned To => codemastr
2003-06-15 16:52 codemastr Note Added: 0002969
2003-06-20 05:59 LRL Status resolved => feedback
2003-06-20 05:59 LRL Resolution fixed => reopened
2003-06-20 05:59 LRL Note Added: 0003003
2003-06-20 06:09 LRL Note Added: 0003004
2003-06-21 14:00 AngryWolf Note Added: 0003006
2003-06-22 10:22 LRL Note Added: 0003022
2003-07-02 14:58 LRL Note Added: 0003151
2003-07-15 18:22 codemastr Note Added: 0003238
2003-07-16 09:47 LRL Note Added: 0003250
2003-07-16 09:50 LRL Note Edited: 0003250
2003-07-16 14:26 codemastr Note Added: 0003251
2003-07-16 21:32 codemastr Note Added: 0003254
2003-07-18 03:05 LRL Note Added: 0003262
2003-07-18 09:25 LRL Note Edited: 0003262
2003-07-18 15:13 codemastr Note Added: 0003275
2003-07-18 21:47 LRL Note Added: 0003282
2003-07-18 22:06 codemastr Note Added: 0003283
2003-07-18 22:13 LRL Note Added: 0003284
2003-07-18 22:16 codemastr Note Added: 0003285
2003-07-29 09:25 LRL Note Added: 0003365
2003-07-29 09:25 LRL File Added: ircd.log
2003-07-29 09:27 LRL Note Added: 0003366
2003-09-05 21:19 syzop Note Added: 0003593
2004-05-26 21:40 syzop Status feedback => closed
2004-05-26 21:40 syzop Note Added: 0006441