View Issue Details

IDProjectCategoryView StatusLast Update
0001403unrealircdpublic2013-05-06 07:03
Reporterm0wlAssigned Tonenolod 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2-beta16 
Target VersionFixed in Version3.4-alpha1 
Summary0001403: Banwalking for Globalops & Serveradmins
DescriptionThe 'rule' that Globalops cannot banwalk if +O is set
and ServerAdmins cannot banwalk if +A is set is a bit unlogical since they could set -O/-A to join the channel.
TagsNo tags attached.
3rd party modules

Activities

White_Magic

2003-12-04 18:18

reporter   ~0004200

but to ban walk, doesnt they need oper override??, and if u dont have over ride u cant ban walk?? did i miss something?

m0wl

2003-12-04 18:38

reporter   ~0004203

If you have can_override you can't banwalk in a +O channel as globalop and +A as a serveradmin, but you can remove the mode (O/A) from outside, so it's useless to deny banwalking if these modes are set if you can remove them.

w00t

2003-12-04 23:55

reporter   ~0004207

Hm. Now m0wl does have a point there... but why bother when, as you said, you can unset those modes? Can someone define the term "banwalk" to me, im a bit in the dark there. Thanks in anticipation.

m0wl

2003-12-05 16:06

reporter   ~0004214

Banwalk = joining although a ban is set against you (/invite me #channel & /join #channel on unreal)

w00t

2003-12-08 01:39

reporter   ~0004242

ok

Understand and agree with m0wl now.

Zell

2006-01-20 16:10

reporter   ~0010987

As of testing today, the bug is still there.

Is this going to be fixed for 3.2.4?

JasonTik

2006-01-20 19:50

reporter   ~0010990

Perhaps we should consider that a global could also do a -O. (Admin doing it is already noted)

1) Not a bug
2) Probabaly not fixed for 3.2.4, because im helping alpha test it, and i havnt seen anything different about this.

Zell

2006-04-13 21:55

reporter   ~0011552

Nope, not fixed.

nenolod

2013-05-06 07:03

reporter   ~0017494

http://hg.unrealircd.org/hg/unreal/rev/08b013b4c0a5

Issue History

Date Modified Username Field Change
2003-12-01 19:44 m0wl New Issue
2003-12-04 18:18 White_Magic Note Added: 0004200
2003-12-04 18:38 m0wl Note Added: 0004203
2003-12-04 23:55 w00t Note Added: 0004207
2003-12-05 16:06 m0wl Note Added: 0004214
2003-12-08 01:39 w00t Note Added: 0004242
2006-01-20 16:10 Zell Note Added: 0010987
2006-01-20 19:50 JasonTik Note Added: 0010990
2006-04-13 21:55 Zell Note Added: 0011552
2006-11-16 16:31 aquanight Category documentation => ircd
2007-04-19 02:47 stskeeps Status new => acknowledged
2013-05-06 07:03 nenolod Note Added: 0017494
2013-05-06 07:03 nenolod Status acknowledged => resolved
2013-05-06 07:03 nenolod Fixed in Version => 3.4-alpha1
2013-05-06 07:03 nenolod Resolution open => fixed
2013-05-06 07:03 nenolod Assigned To => nenolod