View Issue Details

IDProjectCategoryView StatusLast Update
0001416unrealircdpublic2004-02-18 19:21
ReporterZifnab Assigned Tocodemastr 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Summary0001416: allow::options::noident doesn't seem to work
DescriptionI want to let just a fixed ident or ircuser to pass (*!fm@*).
I have tried the following blocks but nothing happend...
allow {
      ip fm@*;
      hostname fm@*;
      class clients; ( With this, noone connects
      password "tatata";
      maxperip 5;
};

allow {
      ip ~fm@*;
      hostname ~fm@*;
      class clients; With this, noone connects.
      password "tatata";
      maxperip 5;
};

allow {
      ip *@*;
      hostname fm@*;
      class clients; With this, everyone connects
      password "tatata";
      maxperip 5;
};

allow {
      ip fm@*;
      hostname *@*;
      class clients; With this, everyone connects
      password "tatata";
      maxperip 5;
};

Well, I also try the ip/hostname part mixed, as in ip ~fm@* and hostname fm@* and the oder way around ip fm@* and hostname ~fm@*.
I also tried NOBODY or anything in the hostname part, so the validation will be done only by the ip line, but clients can connnect only if I put *@*.
Additional Information[Syzop: ident@* works if set::options::check-identd is enabled, but without that and allow::options::noident it doesn't seem to work.. seems like someone simply forgot or something]
TagsNo tags attached.
3rd party modules

Activities

syzop

2003-12-08 18:02

administrator   ~0004248

Hm, well:
allow {
    ip "fm@*";
    hostname "fm@*";
[..]
works, if you enable set::options::identd-check and connect from a host which replies on identd with 'fm'.

but the reason I asked you (I think?) to report it here is that you wanted it without real identd, like allow::options::noident... that does indeed not work at the moment and is a bug :).

Zifnab

2003-12-08 23:29

reporter   ~0004258

well, i have tried removing the noident option in the allow block and setting the identd-check, but it still doesnt work. When i do that, i get the nick followed by [ then @hostname. I supposte after the [ cames de ip address, but i didnt see that in tne conexions attemps.

syzop

2003-12-08 23:49

administrator   ~0004259

well it works fine, so you must be doing something wrong.
Like I said:
- use ip fm@* and hostname fm@*
- do NOT use allow::options::noident
- enable set::options::identd-check
- make sure that when you connect you have a fully working ident server (no ~ in front of your ident)

I dunnow what you mean with '[' etc.

Zifnab

2003-12-08 23:55

reporter   ~0004260

I have ip ~fm@*; hostname ~fm@*;

i remove the noident option part.

then set up identd-check

rehash,

well, noone connects, get:
[com] Unauthorized Connection from Invitado1[@pD9E99blah blah

syzop

2003-12-09 00:00

administrator   ~0004261

Use: fm@* not ~fm@*

I guess we have some communication troubles because of the language...

syzop

2003-12-09 00:02

administrator   ~0004262

[00:53:04] *** Connecting to 192.168.1.2 (6667)
-
Local host: test (192.168.1.1)
-
*** Identd request from 192.168.1.2
*** Identd replied: 1291, 6667 : USERID : UNIX : fm
-
Welcome to the TestNet IRC Network Ein!fm@test.lan
[..]

Zifnab

2003-12-09 00:09

reporter   ~0004263

i have test it as you said, and it works. The problem was the way i was thinking... I though if the clients doesnt have an ident server, and if i allow a ~fm@*, it should work also, but it doesnt. I dont know if this is how it should be, or if it is a problem also.

syzop

2003-12-09 00:13

administrator   ~0004264

ok, good.

yes without ident server it does not work (at the moment), even with allow::options::noident it's not working... that's a bug.

Zifnab

2003-12-09 00:16

reporter   ~0004265

do i need to add a new bug report?? of you take this one??
its running on a red hat 7.3 with kernel 2.4.18-5. Unreal3.2beta19 with anope services 1.5.10. gcc version 2.96

syzop

2003-12-09 00:21

administrator   ~0004266

this one is ok, don't worry ;).

codemastr

2004-02-18 19:21

reporter   ~0005081

Fixed in .2119

Issue History

Date Modified Username Field Change
2003-12-08 09:36 Zifnab New Issue
2003-12-08 18:02 syzop Note Added: 0004248
2003-12-08 18:26 syzop Summary Allow Block - Problem letting pass only one ident... => allow::options::noident doesn't seem to work
2003-12-08 18:26 syzop Additional Information Updated
2003-12-08 23:29 Zifnab Note Added: 0004258
2003-12-08 23:49 syzop Note Added: 0004259
2003-12-08 23:55 Zifnab Note Added: 0004260
2003-12-09 00:00 syzop Note Added: 0004261
2003-12-09 00:03 syzop Note Added: 0004262
2003-12-09 00:09 Zifnab Note Added: 0004263
2003-12-09 00:13 syzop Note Added: 0004264
2003-12-09 00:16 Zifnab Note Added: 0004265
2003-12-09 00:21 syzop Note Added: 0004266
2004-01-18 16:53 codemastr Status new => assigned
2004-01-18 16:53 codemastr Assigned To => codemastr
2004-02-18 19:21 codemastr Status assigned => resolved
2004-02-18 19:21 codemastr Resolution open => fixed
2004-02-18 19:21 codemastr Note Added: 0005081