View Issue Details

IDProjectCategoryView StatusLast Update
0001440unrealircdpublic2007-04-19 02:47
ReportersECuREAssigned Tostskeeps 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformWin32OSWindows XPOS VersionBuild 2600 SP1
Product Version3.2-beta19 
Target VersionFixed in Version3.2.4 
Summary0001440: Client connection Message shows localhost. instead of localhost
Description*** Notice -- Client connecting on port 6667: tw- (tw-@localhost.) [clients]
Steps To ReproduceDo /oper and let a client connect to your server.. ;)
Additional Informationnone
TagsNo tags attached.
3rd party modules

Activities

syzop

2003-12-20 14:50

administrator   ~0004389

Yeah I've seen it before.
What does '/quote dns i' show (as an oper)?

sECuRE

2003-12-20 15:36

reporter   ~0004390

[16:39:24] -irc.foonet.com- Nameserver list has 1 server(s):
[16:39:24] -irc.foonet.com- 0. 194.25.2.129
[16:39:24] -irc.foonet.com- retrans=5 s, retry=4 times
[16:39:24] -irc.foonet.com- Default domain name:
[16:39:24] -irc.foonet.com- End of info.

mustapha88

2003-12-30 05:02

reporter   ~0004458

Yes, someone with a server linked to our network brought a clone onto the network via his server. All notices to do with it had the host as "localhost." instead of "localhost"

syzop

2003-12-30 05:11

administrator   ~0004459

mustapha88: are you on windows too?

mustapha88

2003-12-30 05:53

reporter   ~0004460

The particular server where the "localhost." stuff was occurring on is Windows, yes. I have three *nix servers and two Windows servers.

codemastr

2003-12-30 05:56

reporter   ~0004461

Out of curiosity, what does the Windows "HOSTS" file (I forget the exact path on XP, something like C:\Windows\system32\drivers\etc\HOSTS) say for that IP?

mustapha88

2003-12-30 06:31

reporter   ~0004462

His host file only contains stuff like
127.0.0.1 ace-is-a-shithead.com
(for whatever reason, I don't know)
But nothing for localhost.

syzop

2003-12-30 15:21

administrator   ~0004465

codemastr: my guess is this is the 'default subdomain' stuff :p.

mustapha88

2003-12-30 16:15

reporter   ~0004467

Actually, he informs me that he added that "lame" domain to his hosts file to see if connections coming from localhost would say "connecting at ace-is-a-shithead.com".....But, I am not sure. I do have a localhost entry in my hosts file which looks like:
127.0.0.1 localhost
I will grab the Windows version of Unreal off the site and see if I have the "localhost." issue. I am running on Windows 98, so am not sure if that will make a difference.

mustapha88

2003-12-30 17:14

reporter   ~0004468

OK, I did try it on my system. I did /server localhost and it would always say "Unable to resolve your hostname; using your IP address instead"--Something's up, as I've been able to do that before. Does this "localhost." issue occur on *nix?

syzop

2003-12-30 19:19

administrator   ~0004470

yes win + local subdomain fun. I'm aware of this for some time now (actually since I did the *NIX resolver -> windows already). I get for example 'localhost.testnet' here.

w00t

2005-11-11 05:39

reporter   ~0010705

Out of curiosity, is it possible the new resolver has fixed this?

Bock

2006-11-17 03:50

reporter   ~0012683

Imho after 3.2.4 (c-ares resolver) this bug not actual and need to close.

Issue History

Date Modified Username Field Change
2003-12-20 10:01 sECuRE New Issue
2003-12-20 14:50 syzop Note Added: 0004389
2003-12-20 15:36 sECuRE Note Added: 0004390
2003-12-30 05:02 mustapha88 Note Added: 0004458
2003-12-30 05:11 syzop Note Added: 0004459
2003-12-30 05:53 mustapha88 Note Added: 0004460
2003-12-30 05:56 codemastr Note Added: 0004461
2003-12-30 06:31 mustapha88 Note Added: 0004462
2003-12-30 15:21 syzop Note Added: 0004465
2003-12-30 16:15 mustapha88 Note Added: 0004467
2003-12-30 17:14 mustapha88 Note Added: 0004468
2003-12-30 19:19 syzop Note Added: 0004470
2005-11-11 05:39 w00t Note Added: 0010705
2006-11-17 03:50 Bock Note Added: 0012683
2007-04-19 02:47 stskeeps Status new => resolved
2007-04-19 02:47 stskeeps Fixed in Version => 3.2.4
2007-04-19 02:47 stskeeps Resolution open => fixed
2007-04-19 02:47 stskeeps Assigned To => stskeeps