View Issue Details

IDProjectCategoryView StatusLast Update
0001454unrealircdpublic2003-12-28 15:16
Reporterhafriz Assigned To 
Status resolvedResolutionopen 
Product Version3.2-beta18 
Summary0001454: [BUG] NickServ tried to set +H[..] caused by auspice
Description-CynicNet.KampungChat.Org- *** Notice -- [BUG] server NickServ tried to set +H while user not an oper, para=comkung/+iIH, umodes=286789, please fix your services or if you think it's our fault, report at
TagsNo tags attached.
3rd party modules



2003-12-27 15:21

administrator   ~0004448

which services are that?
any idea what caused it?

it is setting a user (which is +iwaSxq) +iIH which is... interresting.
+i: already set
+I: doesn't exist anymore
+H: setting hideoper but user is not +o [!!]

so if this information is correct then it seems a services bug (the bug seems that services [or whoever] didn't set that person +o but is trying to set +H) :).

usermode is 286789 which is 0x46045:
0x00001 UMODE_INVISIBLE (+i)
0x00004 UMODE_WALLOP (+w)
0x00040 UMODE_SADMIN (+a)
0x04000 UMODE_HIDE (+x)
0x40000 UMODE_KIX (+q)


2003-12-28 09:34

reporter   ~0004451

we are using Auspice 2.8Clean


2003-12-28 13:56

reporter   ~0004452

Oh, auspice...
Yep, I noticed that too.
BUT: That's a services problem.

When someone do /nickserv set mlock +Hiws (modes are an example(H mode only for IRCops)), then
NickServ set +H via svsmode, when the user have identified for the nick. NickServ doesn't look, if the user is an oper or not :)

Fix for that: /msg NickServ set mlock none

Issue History

Date Modified Username Field Change
2003-12-27 13:18 hafriz New Issue
2003-12-27 15:21 syzop Note Added: 0004448
2003-12-28 09:34 hafriz Note Added: 0004451
2003-12-28 13:56 Rocko Note Added: 0004452
2003-12-28 15:16 syzop Status new => resolved
2003-12-28 15:16 syzop Summary Bugs for nickserv => [BUG] NickServ tried to set +H[..] caused by auspice