View Issue Details

IDProjectCategoryView StatusLast Update
0001524unrealircdpublic2005-01-22 13:55
ReporterCnilsAssigned Tocodemastr 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platform*OS*OS Version*
Product Version3.2-beta19 
Target VersionFixed in Version3.2.3 
Summary0001524: Stats for except tkl
DescriptionThere is no way to list the except tkl block.
Any chance of having that added?
TagsNo tags attached.
3rd party modules

Activities

Stealth

2004-11-24 16:02

reporter   ~0008399

Maybe the except ban block should also be added to the except tkl block too... Not sure how easy it would be, but it would be a little more convinient to have a kline type for except tkl. (kline as in /kline and conf klines... though i dont know who would be dumb enough to add themselves to a ban block)

codemastr

2004-11-24 17:53

reporter   ~0008400

What?

Stealth

2004-11-24 18:10

reporter   ~0008401

Basically making except ban as part of the except tkl block.

Instead of:

except ban { mask *@192.168.1.103; };
except tkl { mask *@192.168.1.103; type { gline; gzline; shun; }; };

It would simply be:

except tkl { mask *@192.168.1.103; type { gline; gzline; shun; kline; }; };

Stealth

2004-11-24 18:13

reporter   ~0008402

Also, since I don't know exactly how you want to impliment this:

Maybe there should be a stats flag for the TKL blocks, and the exceptions should also show up in the proper stats (gline gzline shun)

codemastr

2004-11-24 19:59

reporter   ~0008404

Uhh, well except ban is not the same thing as as tkl kline exception. First off, the "ban user" blocks are separate from TKL, so they would not be part of that except block. Furthermore, an except ban overrides both ban ip and ban user. So integrating that into TKL just doesn't seem to make sense to me?

aquanight

2004-11-24 22:07

reporter   ~0008405

Yeah, except tkl{} doesn't have a zline flag, but except ban{} would be both kline and zline...

Back on topic though, probably just merging the except tkl stuff into the existing /stats E/exceptban would work, since I don't know what stats character you could use for it :/ .

codemastr

2004-11-25 14:40

reporter   ~0008413

[quote]probably just merging the except tkl stuff into the existing /stats E/exceptban[/quote]

That sounds like a good solution.

Rocko

2004-11-26 09:30

reporter   ~0008415

Would be a good solution, but then there should be made some differences between gline and zline except tkl, otherwise you just see the host, but not for what that except ban is.

Another thing:
Why is except ban listed under /stats k then?

[15:24:41] *** E test@*.anything.you.like.com
[15:24:41] *** k End of /STATS report

codemastr

2005-01-22 13:55

reporter   ~0008892

Added to /stats E in .235

Issue History

Date Modified Username Field Change
2004-02-09 09:37 Cnils New Issue
2004-11-24 15:49 codemastr Status new => assigned
2004-11-24 15:49 codemastr Assigned To => codemastr
2004-11-24 16:02 Stealth Note Added: 0008399
2004-11-24 17:53 codemastr Note Added: 0008400
2004-11-24 18:10 Stealth Note Added: 0008401
2004-11-24 18:13 Stealth Note Added: 0008402
2004-11-24 19:59 codemastr Note Added: 0008404
2004-11-24 22:07 aquanight Note Added: 0008405
2004-11-25 14:40 codemastr Note Added: 0008413
2004-11-26 09:30 Rocko Note Added: 0008415
2005-01-22 13:55 codemastr Status assigned => resolved
2005-01-22 13:55 codemastr Fixed in Version => 3.2.3
2005-01-22 13:55 codemastr Resolution open => fixed
2005-01-22 13:55 codemastr Note Added: 0008892