View Issue Details

IDProjectCategoryView StatusLast Update
0001592unrealinstallingpublic2004-03-21 14:04
ReporterraistlinmajereAssigned Tocodemastr 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSFreeBSDOS Version4.9
Product Version3.2-RC1 
Target VersionFixed in Version 
Summary0001592: Compiling errors
Descriptiongcc -I../include -I/usr/lib -I/usr/src/Unreal3.2/extras/regexp/include -pipe -g -O2 -funsigned-char -DZIP_LINKS -export-dynamic -o ircd auth.o aln.o badwords.o channel.o cloak.o crule.o dbuf.o events.o fdlist.o hash.o help.o ircd.o ircsprintf.o list.o lusers.o match.o modules.o packet.o parse.o res.o res_init.o res_comp.o res_mkquery.o res_skipname.o s_auth.o s_bsd.o s_conf.o s_debug.o s_err.o s_extra.o s_kline.o s_misc.o s_numeric.o s_serv.o s_svs.o socket.o ssl.o s_user.o scache.o send.o support.o umodes.o s_stats.o version.o webtv.o whowas.o zip.o cidr.o random.o extcmodes.o extbans.o -lcrypt -lz -L../extras/regexp/lib -ltre
../extras/regexp/lib/libtre.a(regerror.o): In function `regerror':
/usr/src/Unreal3.2/extras/tre-0.6.4/lib/regerror.c:66: undefined reference to `libintl_gettext'
Steps To Reproduce./Config && make (at least on my box ;)
Additional InformationNot sure what's relevant here..

Gettext 0.13 is in /usr/lib
GCC 3.3
glib 2.2.3

I went thru the steps at http://www.haible.de/bruno/gettext-FAQ.html#integrating_undefined and my answers are all 'no.' The final response is, "If no: The gettext maintainers take no responsibilities for lookalikes named CY_GNU_GETTEXT, AM_GLIB_GNU_GETTEXT, AM_GNOME_GETTEXT and similar, or for homebrewn autoconf checks. Complain to the package maintainer."

Also tried 20040224 CVS-same error.
TagsNo tags attached.
3rd party modules

Activities

codemastr

2004-02-25 16:43

reporter   ~0005206

Would you be able to attach the Unreal3.2/extras/tre-0.6.4/config.log to this bug report?

2004-02-26 02:35

 

config.log (48,563 bytes)

raistlinmajere

2004-02-26 14:10

reporter   ~0005218

My bad about not realizing there was another log, btw. But, of course, the problem is still there. I've installed programs that use Gettext just fine and I just downloaded and installed Gettext a few days ago anyway.

codemastr

2004-02-26 18:20

reporter   ~0005220

Ok thanks, I just read that URL you included, any chance you could also include your config.status (from the same directory)?

syzop

2004-02-27 16:50

administrator   ~0005234

Last edited: 2004-03-02 15:37

[deleted stuff from Rocko about an irrelevant issue (sig11 problem)]

edited on: 2004-03-02 15:37

codemastr

2004-03-04 18:21

reporter   ~0005299

Uhh... well, any progress with sending the config.status?

syzop

2004-03-05 20:58

administrator   ~0005314

Whatever it is/was, you are too late now to have this fixed in next release (RC2).

codemastr

2004-03-18 17:57

reporter   ~0005529

If you open the Makefile, and add -lintl

To the IRCDLIBS= line, does that fix it?

raistlinmajere

2004-03-21 13:35

reporter   ~0005560

My apologies for not getting back here sooner but some major issues came up that I had to deal with. Anyway, I added -lintl and it works! Thanks man! :-)

codemastr

2004-03-21 14:04

reporter   ~0005561

This is fixed in .2193. It will now try and autodetect if -lintl is needed.

Issue History

Date Modified Username Field Change
2004-02-25 14:54 raistlinmajere New Issue
2004-02-25 16:43 codemastr Note Added: 0005206
2004-02-26 02:35 raistlinmajere File Added: config.log
2004-02-26 14:10 raistlinmajere Note Added: 0005218
2004-02-26 18:20 codemastr Note Added: 0005220
2004-02-27 16:50 syzop Note Added: 0005234
2004-02-27 16:51 syzop Note Edited: 0005234
2004-03-02 15:37 syzop Note Edited: 0005234
2004-03-04 18:21 codemastr Note Added: 0005299
2004-03-05 20:58 syzop Note Added: 0005314
2004-03-18 17:57 codemastr Note Added: 0005529
2004-03-21 13:35 raistlinmajere Note Added: 0005560
2004-03-21 14:04 codemastr Status new => resolved
2004-03-21 14:04 codemastr Resolution open => fixed
2004-03-21 14:04 codemastr Assigned To => codemastr
2004-03-21 14:04 codemastr Note Added: 0005561